Bug 39686 - gcc internal error building mozilla 0.9 (--target=i686)
gcc internal error building mozilla 0.9 (--target=i686)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 12:05 EDT by Ed Price
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-08 16:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Price 2001-05-08 12:05:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
[root@wpax MOZILLA]# rpm -iv mozilla-0.9-0.src.rpm
[root@wpax MOZILLA]# cd /usr/src/redhat/SPECS
[root@wpax SPECS]# ls -l
total 20
-rw-r--r--    1 root     root        20176 May  7 15:36 mozilla-0.9.spec
[root@wpax SPECS]# rpm -bb --target=i686 mozilla-0.9.spec
Building target platforms: i686
[...]
nsPresShell.cpp: In method `nsresult PresShell::AddDummyLayoutRequest
()':
nsPresShell.cpp:5913: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

In the directory  /usr/src/redhat/BUILD/mozilla/layout/html/base/src
The following command failed to execute properly:
c++ -o nsPresShell.o -c -DBUILD_OFFICIAL -DOSTYPE="Linux2.4"
-DOSARCH="Linux" -\DOJI -D_IMPL_NS_HTML -I../../../../dist/include
-I../../../../dist/include
-I/u\sr/src/redhat/BUILD/mozilla/dist/include/nspr
-I./../../../xul/base/src -I./../\../../xul/content/src -I./../../style/src
-I./../../forms/src -I./../../../base\/src -I. -I/usr/X11R6/include -fPIC
-I/usr/X11R6/include -fno-rtti -fno-excepti\ons -Wall -Wconversion
-Wpointer-arith -Wbad-function-cast -Wcast-align -Woverl\oaded-virtual
-Wsynth -Wshadow -pedantic -Wno-long-long -pipe -pthread -O -DNDE\BUG
-DTRIMMED -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../../../config\-defs.h -Wp,-MD,.deps/nsPresShell.pp nsPresShell.cpp
make[4]: *** [nsPresShell.o] Error 1


How reproducible:
Didn't try


Additional info:

this is standard gcc-2.96-81, redhat-7.1 on a thinkpad t20.
Comment 1 Jakub Jelinek 2001-05-08 16:56:49 EDT
Please check if it is reproduceable, if it is, rerun the above
c++ command with -save-temps -v options in addition to those
you posted and attach here nsPresShell.ii it creates. Thanks.
Comment 2 Ed Price 2001-05-09 09:51:28 EDT
i could not reproduce this -- at least not exactly...

it fails every time (4 out of 4) but in a different place each time.
presumably this is not a bug in gcc, but some kind of hardware problem, or
kernel problem, or something?

(when i rerun the "c++" command after it fails, it completes successfully.)

please feel free to delete/resolve this bug, and please excuse my ignorance of
bugzilla.

i would appreciate any advice on how to track down this problem, however!!!

(gcc also fails to rebuild itself for --target=i686, in a similar fashion -- the
first time it got ICE from stage2 compiler in some java thing, the second time
the assembler complained about ".p2almgn", which somehow was substituted for
".p2align" -- ie weird random corruption!?  very disturbing!)

thanks.

Note You need to log in before you can comment on or make changes to this bug.