Bug 3970 - kickstart with --iscrypted problem.
kickstart with --iscrypted problem.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-09 17:31 EDT by dmartin
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 18:19:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dmartin 1999-07-09 17:31:23 EDT
I have been trying to set up a kickstart install, and use
the rootpw --iscrypted option.  I noticed on the errata page
that there was a bug listed #2460 that says the installer
recrypts the encrypted hash, and that there is a new boot
image that fixes this.  I downloaded the new bootnet.img and
it is still broken. The password is still being recrypted.

I looked at the log for bug #2460 and it states that the bug
was resolved, but it definitely is not. There are also
comments from other people at the end that say that they
also have seen this same problem with the new bootnet.img
file.

I have a gazillion linux boxes to set up next week so if at
all possible it would be great if this could be fixed by
Monday! :)

Thanks
Comment 1 Bill Nottingham 1999-07-09 18:31:59 EDT
*** Bug 3972 has been marked as a duplicate of this bug. ***



the graphic profiler gprof which is part of the binutils
suite shipped with red hat 6.0 - alpha
(binutils-2.9.1.0.23-4) seg faults dumping core.
Comment 2 helmut katzgraber 1999-07-09 18:44:59 EDT
bug 3970 has nothing to do with bug 3972, at least when i look at it
trought he net it is about rootpw --iscrypted option on i386
machines?!?!?
Comment 3 dmartin 1999-07-14 11:20:59 EDT
Looking for an update to this bug report.  There has been no update
since it was opened other than an eroneous one about another problem
being a duplicate of it.
Comment 4 Bill Nottingham 1999-07-15 13:44:59 EDT
the problem lies in that it's the second stage installer that
does this processing. You need to download the new supp.img,
and either use that, or replace the install2 binary on the
installation image with the new one.
Comment 5 dmartin 1999-07-15 14:18:59 EDT
I have no idea what you are talking about.  I do not use a
supplementary image. I'm never prompted for one nor do I need one.  It
would seem to be counterproductive to kickstart, since I would have to
wait until the install process is done with the first to switch disks.

It is my understanding that the supp.img disk image is not a bootable
image. How would I go about using this disk as part of a kickstart
install?  PLEASE ELABORATE.
Comment 6 David Lawrence 1999-07-15 18:19:59 EDT
To fix the root --iscrypted problem you will need to download the
second stage
install binary from out rawhide ftp site.
This will unfortunately only work with either an nfs install image or
with a CD that you record yourself with the fix in place.

You can obtain the second stage install binary from
ftp://rawhide.redhat.com/i386/RedHat/instimage/usr/bin/install2

You can either just overwrite the old install2 in your nfs install
path located
at:

<nfs path>/RedHat/instimage/usr/bin/install2

or you can replace the same and reburn a new CD for installing from
CD.
We will be updating the errata page the reflect the changed solution
for this
type of bug.
Comment 7 Bill Nottingham 1999-07-15 18:30:59 EDT
*** Bug 2880 has been marked as a duplicate of this bug. ***

rootpw --iscrypted somecryptedpasswd does not work

It's supposed to put that string, verbatim, into root's
password entry in /etc/passwd.  When booting from
a rescue disk I discovered that it places a
different string there.

This worked correctly under 5.2.

This is a show-stopper for us, and is preventing us
from installing Redhat Linux 6.0 across our installation.


------- Additional Comments From dkl@redhat.com  05/17/99 19:13 -------
This has been verified to be a problem.

------- Additional Comments From msw@redhat.com  05/28/99 19:51 -------


*** Bug 2460 has been marked as a duplicate of this bug. ***

When using kickstart to install a machine, I used an already
encrypted password. When it rebooted I couldn't log in as
root. After some investigating, I found out if I presented
the password hash I had specified in the kickstart file, it
would then let me log in.

In other words, during the install, the encrypted password
was encrypted again.

------- Additional Comments From gordon.m.tetlow@vanderbilt.edu  05/01/99 02:29 -------
I checked the value of skipCrypt and found it to be 0 after the call
to poptGetContext inside of setRootPassword inside install2.c

This seems to be the problem, although why the poptGetContext is
returning skipCrypt as 0 is beyond me.

Gordon

------- Additional Comments From dkl@redhat.com  05/10/99 15:52 -------
I have verified this on a test lab machine.

------- Additional Comments From dkl@redhat.com  05/10/99 15:54 -------


*** Bug 2627 has been marked as a duplicate of this bug. ***


When doing a kickstart installation with RedHat 6.0
(kickstart is great!) and writing something like

rootpw --iscrypted 8d78LWoez74ef

in the kickstart file sets the root password to "8d78LWoe".
--iscrypted still worked in 5.2.  I quickly looked through
the code in install2, but there were little changes in
the password code, so I could not figure the problem out.
I have --useshadow in auth config.

------- Email Received From  Justin Sheehy <justin@linus.mitre.org> 06/15/99 10:22 -------


------- Additional Comments From dkl@redhat.com  06/17/99 18:58 -------


*** Bug 3517 has been marked as a duplicate of this bug. ***

In ref to Bug 2640. This still appears to be a problem. I
have downloaded the new bootnet.img from updates.redhat.com
and am still seeing the same problem.

------- Additional Comments From msmith@exodus.net  06/17/99 13:23 -------
Sorry ref to Bug 2460
Comment 8 Mike Smith 1999-08-06 19:31:59 EDT
Can someone confirm if this is working??? I have downloaded the new
install2 and slapped it on the ftp server. I am still seeing the same
problem. It still recrypts the passwd. This should work with an ftp
install as well right ?
Comment 9 scott 1999-09-11 17:59:59 EDT
I'm glad this bug has been fixed, but the fix is no longer present on
the rawhide ftp site. The install2 binary is missing. Worse still, the
source code is nowhere to be found, and I need that since I have to
patch the install2 program to work correctly at my site (we don't want
any logical paritions created automatically, only primary partitions).

Where can I obtain the source for install2, or at least the patch to
fix the --iscrypted problem?

Note You need to log in before you can comment on or make changes to this bug.