Bug 39709 - Creating large filesystems may take extremely long time.
Summary: Creating large filesystems may take extremely long time.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 19:21 UTC by Bryan Leopard
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-08-26 15:17:15 UTC


Attachments (Terms of Use)

Description Bryan Leopard 2001-05-08 19:21:24 UTC
Description of Problem:

Creating a large ext2 filesystem on Smart Array 5300 may take an 
extraordinarily long time to complete. The process starts out normally, 
but slows during the creation of the inode tables.
Creating a filesytem of about 175gB on an ADG volume took about 8 to 10 
minutes to complete. Creating the same filesystem when using the 2.4.3 
tree downloaded fron kernel.org completed within a couple of minutes.
Current configuration:
Compaq IA64 System pilot-4 w/2 C0 processors & 8gB RAM
Smart Array 5300 in slot 2 w/2 logical volumes
Smart Array 5300 in slot3 w/2 logical volumes
Boot controller: Smart Array 5300 Controller

Comment 1 Aaron Brown 2001-05-08 19:38:28 UTC
You filed this under i386, but reported observing the problem on an IA-64.
Have you observed this on i386 as well?

Please remember to file Itanium defects under ia64 in the future.

Comment 2 Florian La Roche 2001-05-08 20:02:19 UTC
What beta version have you tried this with? What is the kernel version?

Thanks,

Florian La Roche


Comment 3 Bryan Leopard 2001-05-10 14:21:16 UTC
This was tried with Beta 3 and kernel 2.4.3.

Comment 4 Florian La Roche 2001-05-16 08:01:32 UTC
Re-assigned to the kernel.

Comment 5 Arjan van de Ven 2001-05-16 08:21:13 UTC
Al, is this the O(N^2) buffer algo ?

Comment 6 Glen Foster 2001-07-13 20:09:55 UTC
This defect considered SHOULD-FIX for Fairfax gold-release.

Comment 7 Arjan van de Ven 2001-08-02 19:51:12 UTC
It would be very interesting to know if the 2.4.7-0.4 kernel still has this
behavior; the relevant kernelcode is totally rewritten to get rid of bad
algorithms and such.

Comment 8 Bryan Leopard 2001-08-02 20:21:27 UTC
Comments from Compaq Engineer

The comments from RedHat indicate they have their own 2.4.7 (version 2.4.7-
0.4). When will we see that? Or do they want to know if it's fixed in the 
kernel.org tree?

Comment 9 Arjan van de Ven 2001-08-02 20:28:24 UTC
2.4.7-0.3 was released to the betatime about half an hour ago, that's the same
as 2.4.7-0.4 which will have a rpm depenency fix in it.



Note You need to log in before you can comment on or make changes to this bug.