Bug 39711 - anaconda: raise ValueError, no root device has been set
anaconda: raise ValueError, no root device has been set
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 15:30 EDT by Danny Rice
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 16:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (11.18 KB, text/plain)
2001-05-08 15:32 EDT, Danny Rice
no flags Details
dmesg from current boot (6.50 KB, text/plain)
2001-05-08 15:32 EDT, Danny Rice
no flags Details

  None (edit)
Description Danny Rice 2001-05-08 15:30:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686; Nav)

Description of problem:
When upgrading from 7.0 to 7.1 after choosing to Upgrade then
choosing Next on the customize packages screen I get the traceback
in the accompanying attachment:

How reproducible:
Always

Steps to Reproduce:
1.upgrade from 7.0 to 7.1 cd, ftp, and nfs install
2.choose upgrade then select next at following screen

Actual Results:  window pops up saying there is a bug and report it to
bugzilla with the traceback

Expected Results:  should have started the upgrade

Additional info:

The dmesg from the current boot is included in an attachment to give
information about my system:
Comment 1 Danny Rice 2001-05-08 15:32:02 EDT
Created attachment 17748 [details]
anaconda traceback
Comment 2 Danny Rice 2001-05-08 15:32:53 EDT
Created attachment 17749 [details]
dmesg from current boot
Comment 3 Brent Fox 2001-05-08 17:39:48 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?
Comment 4 Danny Rice 2001-05-09 12:30:53 EDT
Using 'linux ide=nodma' gives the same result.  I looked at the Alt-F4 log and
get something like the following.  This all happens before the graphical
interface pops up and doesn't seem to go any further after the anaconda
exception.

Pretty normal looking up to here.  Looks like scsi stuff is detected etc.
<6>sdb: sdb1
<7>ISO 9660 Extenstions: RRIP_1991A
<4>Unable to identify CD-ROM format
<6>raid0 personality regestered as nr 2
<6>raid1 personality regestered as nr 3
<6>raid5: measuring checksumming speed
...
  some numbers/speeds
...
<4>raid5: using function: p5_mmx (1168.00 MB/sec)
<6>raid5 personality registered as nr 4

Then that's it except that the time that I recorded this, two of my disks were
at maximal mount count and I was getting warnings about it like.
<4>EXT2-fs: maximal mount count reached, ...

I don't know what all the raid stuff is about.  I have never explicitely
included any raid support.  On a normal boot I get a message like:

autodetecting RAID arrays
autorun ...
... autorun DONE.

instead of all the details.
Comment 5 Brent Fox 2001-05-09 17:39:17 EDT
Can you boot into your 7.0 system and post the output of the 'mount' command. 
Also, 'fdisk -l /dev/hda' would be nice.
Comment 6 Danny Rice 2001-05-09 18:14:55 EDT
$ mount
/dev/sda3 on / type ext2 (rw,usrquota)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda1 on /sda1 type ext2 (rw)
/dev/sda2 on /boot type ext2 (rw)
/dev/sdb1 on /sdb1 type ext2 (rw,usrquota)
/dev/hda2 on /hda2 type ext2 (rw,usrquota)
none on /dev/pts type devpts (rw,gid=5,mode=620)
walrus:/c1 on /nfs/walrus type nfs (rw,rsize=8192,wsize=8192,addr=129.79.225.52)

$ fdisk -l /dev/hda
 
Disk /dev/hda: 255 heads, 63 sectors, 3739 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       510   4096543+   b  Win95 FAT32
/dev/hda2           511      3739  25936942+  83  Linux

Also here is sda which is where the / (root) and /boot partitions are.

fdisk -l /dev/sda
 
Disk /dev/sda: 255 heads, 63 sectors, 2213 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/sda1             1       130   1044193+  83  Linux
/dev/sda2           131       132     16065   83  Linux
/dev/sda3           133      2181  16458592+  83  Linux
/dev/sda4          2182      2213    257040    5  Extended
/dev/sda5          2182      2197    128488+  82  Linux swap
/dev/sda6          2198      2213    128488+  82  Linux swap
Comment 7 Brent Fox 2001-05-14 22:03:27 EDT
Ok, it looks like /dev/sda3 is your / partition.  Do any of your other Linux
partitions contain an /etc/fstab file?  

I'm curious if disconnecting the IDE hard drive would have any effect.
Comment 8 Danny Rice 2001-05-15 15:35:32 EDT
There are no other /etc/fstab files anywhere.  I think I see the problem. I am
having lilo install the boot loader on the IDE MBR boot=/dev/hda.  I think I
ended up doing this because I couldn't get it to work when I loaded it on
/dev/sda.  Can you verify that this is likely the problem without me messing
with it first?  What solution would you recommend in terms of the boot loader if
this is the problem?  Here is my lilo.conf:

#disk=/dev/sda bios=0x80
#boot=/dev/sda
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
linear
default=linux
message=/boot/message
 
image=/boot/linux-2.2.19
        label=linux
        initrd=/boot/initrd-2.2.19-7.0.1.img
        read-only
        root=/dev/sda3
 
image=/boot/bzImage-2.2.19
        label=linux3
        read-only
        root=/dev/sda3

image=/boot/vmlinuz-2.2.19-7.0.1
        label=linux2
#       initrd=/boot/initrd-2.2.19-7.0.1.img
        read-only
        root=/dev/sda3
 
other=/dev/hda1
        label="Windows 98"
Comment 9 Brent Fox 2001-05-16 15:47:44 EDT
No, there should be no problem with installing lilo to the MBR of the SCSI drive.
Comment 10 Danny Rice 2001-05-21 16:11:42 EDT
I disconnected the IDE drive and am still getting the exact same error when I
try to upgrade from 7.0 to 7.1.
Comment 11 Brent Fox 2001-05-21 16:46:19 EDT
The problem could be that your /etc/lilo.conf file has the line:
boot=/dev/hda
but it sounds like /dev/sda is your root device.  If you have disconnected the
IDE drive, the line should be "boot=/dev/sda"


Comment 12 Danny Rice 2001-05-21 16:53:18 EDT
I was previously installing the boot loader on hda but changed it to sda before
I disconnected hda (ie.  I already added the "boot=/dev/sda" line in lilo.conf).
I made sure I was able to boot with hda disconnected before I tried to do the
upgrade without hda.
Comment 13 Lars Ljung 2001-05-24 07:50:39 EDT
I have the same problem while upgrading from 6.2 to 7.1 (the same traceback).
Here is my /etc/fstab:

/dev/hdb3	/		ext2	defaults		1 1
/dev/hdb1	/usr		ext2	defaults,ro		1 1
/dev/hdb4	/home		reiserfs defaults,nosuid,nodev	1 1
/dev/hda1	/mnt/DOS	vfat	user,noauto,rw		0 0
/dev/hdc    /mnt/cdrom	iso9660	user,noauto,ro		0 0
/dev/fd0	/mnt/floppy	ext2	user,noauto		0 0
/dev/sda4	/mnt/zip	vfat	user,noauto		0 0
/dev/sda1	/mnt/zip	vfat	user,noauto		0 0
/dev/hdb2	none		swap	sw
proc		/proc		proc	defaults

My partitions looks like this:

Disk /dev/hda: 64 heads, 63 sectors, 621 cylinders
Units = cylinders of 4032 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       621   1251904+   c  Win95 FAT32 (LBA)
Partition 1 has different physical/logical endings:
     phys=(619, 63, 63) logical=(620, 63, 63)

Disk /dev/hdb: 128 heads, 63 sectors, 782 cylinders
Units = cylinders of 8064 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1       573   2310304+  83  Linux
/dev/hdb2           766       782     68544   82  Linux swap
/dev/hdb3           574       701    516096   83  Linux
/dev/hdb4           702       765    258048   83  Linux
Comment 14 Danny Rice 2001-05-30 11:27:35 EDT
As an experiment I installed 7.1 on a different partition.  Unlike the upgrade
attempts everything worked fine.
Comment 15 Danny Rice 2001-05-30 16:15:58 EDT
After editing my /etc/fstab I was able to upgrade from 7.0 to 7.1 with no
problem.  The original /etc/fstab was:

/dev/sda3       /               ext2    defaults,usrquota               1 1 #
15  G
/dev/sda1       /sda1           ext2    defaults                        1 0 #
1   G
/dev/sda2       /boot           ext2    defaults                        1 2 #
16  M
/dev/sda5       swap            swap    defaults                        0 0 #
128 M
/dev/sda6       swap            swap    defaults                        0 0 #
128 M

/dev/sdb1       /sdb1           ext2    defaults,usrquota               1 2 #
8.5 G

/dev/hda1       /mnt/W98        vfat    noauto                          0 0 #
3.9 G
/dev/hda2       /hda2           ext2    defaults,usrquota               1 2
#24.7 G

/dev/fd0        /mnt/floppy     ext2    owner,noauto                    0 0
/dev/cdrom      /mnt/cdrom      iso9660 owner,noauto,ro                 0 0

none            /proc           proc    defaults                        0 0
none            /dev/pts        devpts  gid=5,mode=620                  0 0


herbie:/linux   /nfs/herbie     nfs     noauto,rsize=8192,wsize=8192    0 0
walrus:/c1      /nfs/walrus     nfs     rsize=8192,wsize=8192           0 0

dugong:/        /nfs/dugong     nfs     noauto,rsize=8192,wsize=8192    0 0

Before I upgraded I removed the comments at the end of the entries and commented
out the unneccesary partitions to give.

/dev/sda3       /               ext2    defaults,usrquota               1 1
#/dev/sda1      /sda1           ext2    defaults                        1 0
/dev/sda2       /boot           ext2    defaults                        1 2
/dev/sda5       swap            swap    defaults                        0 0
/dev/sda6       swap            swap    defaults                        0 0

#/dev/sdb1      /sdb1           ext2    defaults,usrquota               1 2

#/dev/hda1      /mnt/W98        vfat    noauto                          0 0
#/dev/hda2      /hda2           ext2    defaults,usrquota               1 2

/dev/fd0        /mnt/floppy     ext2    owner,noauto                    0 0
/dev/cdrom      /mnt/cdrom      iso9660 owner,noauto,ro                 0 0

none            /proc           proc    defaults                        0 0
none            /dev/pts        devpts  gid=5,mode=620                  0 0


#herbie:/linux  /nfs/herbie     nfs     noauto,rsize=8192,wsize=8192    0 0
#walrus:/c1     /nfs/walrus     nfs     rsize=8192,wsize=8192           0 0
#dugong:/       /nfs/dugong     nfs     noauto,rsize=8192,wsize=8192    0 0

I guess anaconda didn't like my original fstab file.
Comment 16 Brent Fox 2001-05-31 15:16:52 EDT
It could be that mid-line '#' characters in /etc/fstab don't get handled nicely
by the installer.
Comment 17 Lars Ljung 2001-06-04 09:21:45 EDT
I had some tab characters in my fstab,  I solved the problem by replacing those
with spaces.
Comment 18 Brent Fox 2001-07-03 16:07:28 EDT
I don't think that tab versus spaces should make a difference, but putting
mid-line '#' (comment) marks will cause problems.  I think that, as a general
rule, comments should only be used at the beginning of the line in the
/etc/fstab file.

Note You need to log in before you can comment on or make changes to this bug.