Bug 397111 - Keyboard and mouse hang on 2.6.24-0.41.rc3.git1 with orinoco PCMCIA
Summary: Keyboard and mouse hang on 2.6.24-0.41.rc3.git1 with orinoco PCMCIA
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-23 17:45 UTC by Bryan Christ
Modified: 2008-01-09 22:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 22:44:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Christ 2007-11-23 17:45:39 UTC
Description of problem:

After plugging in and orinoco PCMCIA wireless adapter, the keyboard and mouse
freeze after about 4 minutes.  The HID can be unfrozen by ejecting the orinoco
card.  This does not happen on the 2.6.23.1-42 kernel or previous kernels.

The system being used for test is an HP Compaq nc6000 notebook

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.  Install Fedora 7 with latest updates.
2.  Install 2.6.24-0.41.rc3.git1 kernel from development yum repo
3.  Insert orinico PCMCIA card (my card is Linksys)
4.  Configure card with iwconfig
5.  Transfer data for about 4 minutes
  
Actual results:

Keyboard and mouse eventually freeze.

Expected results:

Additional info:

Comment 1 Kyle McMartin 2007-11-28 14:55:22 UTC
Can you switch to a virtual terminal (Control-Alt-F1) after starting the data
transfer, to see if there is a kernel panic or other system message? If so,
please capture the data somehow (photo) and attach it to this bug report.

cheers, Kyle

Comment 2 Bryan Christ 2007-12-10 21:34:26 UTC
Not really possible...

1.  The kernel does not panic.  Once I eject the card, the system unfreezes.
2.  Because the keyboard is frozen and I cannot switch VTs while it is frozen.

I'm pretty sure I checked dmesg after the hang, but didn't see anything.  I will
try again and post an update.

Comment 3 Bryan Christ 2008-01-04 23:47:34 UTC
I spent a day running the offending kernel again, and never saw the problem.  I
suggest closing for now and I will keep watching for the problem in the future.

Comment 4 Pete Zaitcev 2008-01-09 22:44:36 UTC
So we don't know where it was spinning, that's too bad. I hoped the NMI
oopser would catch it. I'm closing this for now.


Note You need to log in before you can comment on or make changes to this bug.