Bug 397161 - yum broke library dependency
yum broke library dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 13:17 EST by Pierre Ossman
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 17:04:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2007-11-23 13:17:18 EST
On the 19th yum decided to pull in a new libdvdread even though other packages
depended on the old version. Hence, those programs can no longer run.

apt-get check confirms that yum has made a mess of thing:

[root@poseidon ~]# apt-get check
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  gstreamer-plugins-ugly: Depends: libdvdread.so.3
  mencoder: Depends: libdvdread.so.3
  mplayer: Depends: libdvdread.so.3
  mplayer-gui: Depends: libdvdread.so.3

(a yum check would be nice, but that's another issue)

I don't see how the dependency tree would allow such an update?
Comment 1 Pierre Ossman 2007-11-23 17:37:26 EST
I can now reproduce this. I downloaded the old packages (libdvdread and
libdvdnav from koji and livna) and downgraded. I then proceeded to attempt an
upgrade.

Command line yum refuses to break the system (or at least I can't find a way).
It always detects that it will break a dependency. So everything is green there.

Pirut however! Clicking go the first time gives me an error about breaking
dependencies. Clicking a second time gives me the same error. But clicking a
third time causes it to proceed carelessly!

(The reason I got hit by this the first time was that I had a whole bunch of
updates where some wouldn't apply. So it took me a few attempts to figure out
what to unselect.)
Comment 2 Jeremy Katz 2007-11-26 11:31:37 EST
Thanks for the full details on reproducing.  Fixed both in upstream yum (so that
API users can't hit this case) and worked around in pirut.  Will be in pirut >=
1.3.27
Comment 3 Fedora Update System 2007-11-28 20:34:08 EST
pirut-1.3.27-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pirut'
Comment 4 Pierre Ossman 2007-12-03 04:57:17 EST
I have pirut-1.3.27-1.fc9 and problem is still there. Only now, it proceeds on
the second attempt instead of the third.

yum is not updated though, so it's the extra check in pirut that is somehow
ineffective.
Comment 5 Fedora Update System 2007-12-06 15:45:36 EST
pirut-1.3.28-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-12-06 15:55:13 EST
pirut-1.3.28-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Pierre Ossman 2007-12-06 23:43:33 EST
Bug is still there in 1.3.28. Now I also have yum 3.2.7-2, so the check should
be there as well.
Comment 8 Seth Vidal 2007-12-06 23:49:39 EST
just for sanity's sake - grab yum 3.2.8 and make sure you still see this?
Comment 9 Pierre Ossman 2007-12-09 13:05:24 EST
Tested, and I can no longer provoke the problem in pirut.

Note You need to log in before you can comment on or make changes to this bug.