Bug 397241 - recordmydesktop: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
recordmydesktop: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' fai...
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: recordmydesktop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 15:12 EST by darrell pfeifer
Modified: 2008-04-18 11:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 07:48:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log (1.91 KB, text/plain)
2007-11-23 15:12 EST, darrell pfeifer
no flags Details

  None (edit)
Description darrell pfeifer 2007-11-23 15:12:02 EST
Description of problem:

recordmydesktop: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

Version-Release number of selected component (if applicable):

recordmydesktop-0.3.6-1.fc9

libxcb-1.1-1.fc9
xorg-x11-server-Xorg-1.3.0.0-33.fc8

How reproducible:

Run gtkrecordmydesktop or recordmydesktop on the latest rawhide

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Recording dies after about 30 seconds

Expected results:


Additional info:

Sun Java is also caught by the same problem



bz 254144
Comment 1 darrell pfeifer 2007-11-23 15:12:02 EST
Created attachment 267801 [details]
crash log
Comment 2 Greg Manhart 2007-11-28 04:44:19 EST
I think this is the same thing as in SUSE
JAVA apps fails with "xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock'
failed" 
https://bugzilla.novell.com/show_bug.cgi?id=251087

this currently makes BOINC not work for seti@home
Comment 3 Nic Doye 2007-12-09 08:50:51 EST
Googling, I see that it's also been discussed on a Gentoo forum
http://forums.gentoo.org/viewtopic-t-613715.html 

I've come across this using MyEclipse with a non-Fedora Eclipse 3.3 installation
and also Netbeans 6.0. Both Sun Java 5 and 6 (jdk-1.5.0_13-fcs jdk-1.6.0_03-fcs
RPMs) exhibit this behaviour. However, the IcedTea version (
java-1.7.0-icedtea-devel-1.7.0.0-0.19.b21.snapshot.fc8 ) is fine in this regard.  

(Although NB 6.0 isn't actually stable on IcedTea). 

I'm no X11 expert, but there would appear to be an option that needs adding to
one of Fedora's X11 packages - the Gentoo post implies something like:

1) add "xcb" to the USE flag
2) recompile "x11-libs/libX11" 

(which maps to libxcb RPM for Fedora 8). This is identical to the fix mentioned
in the above Novell bug report.

nic
Comment 4 Matěj Cepl 2008-01-10 07:48:30 EST

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.