Bug 397461 - Xorg -configure is broken
Xorg -configure is broken
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On:
  Show dependency treegraph
Reported: 2007-11-23 16:39 EST by Christian Krause
Modified: 2008-02-27 06:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-27 06:38:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
new version of the patch (2.57 KB, patch)
2007-11-23 16:39 EST, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2007-11-23 16:39:52 EST
Description of problem:
Since F8 it is not possible anymore to use "X -configure" to let the X server
generate a default config for the current hardware.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. X -configure
Actual results:
"Missing output drivers.  Configuration failed."

Expected results:
"Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/xorg.conf.new

To test the server, run 'X -config /root/xorg.conf.new'

Additional info:
The problem is caused by one of the applied patches: 

This patch changes the file xorg-server- and
reverts the meaning of the following statement:
-                   if (!(stat(buf, &stat_buf) == 0 &&
-                         S_ISREG(stat_buf.st_mode)))
+                   if (dp->d_type == DT_REG)

Before the patch it will not proceed the loop if the file isn't a regular one.
After the patch it will not proceed the loop if the file is a regular one (and
so it doesn't find any output drivers and so it doesn't work. ;-) ).

IMHO the part of this patch file which changes loadmod.c are not really
necessary or change any behavior. I suggest that they are removed from the patch

I'll attach a corrected diff.
Comment 1 Christian Krause 2007-11-23 16:39:52 EST
Created attachment 267811 [details]
new version of the patch
Comment 2 Christian Krause 2007-12-29 16:45:26 EST
Any news regarding this issue? Is there anything I can do to help to fix the
X.org package?
Comment 3 Matěj Cepl 2008-01-10 11:54:20 EST
Does system-config-display works for you? Are you able to start X when remove
/etc/X11/xorg.conf completely? I am afraid we don't care that much about X
-configure anymore.
Comment 4 Christian Krause 2008-01-10 14:56:49 EST
Actually system-config-display doesn't work with my dual-head configuration (but
this is a different problem)
when using system-config-display without a xorg.conf it basically works (unless
dual-head is configured, then the config cannot be saved)
IMHO these system-config-display problem should be handled separately. ;-)

Starting X without having an /etc/X11/xorg.conf works.

I understand that "X -configure" is probably not a common use case anymore. But
a co-worker stumbled over this and I've given it a shot to check for the
problem. It turned out that it was caused by one of the patches from Fedora, so
I've thought I should report the problem. ;-)

Please can you review my investigation I've put into the description and the
attached patch? The problem only occurs because there is a (broken) patch
applied when building the package. Because the broken chunks of the patch does
not even have an effect to fix the (original) bug which the patch was created
for (some ps2 problems), I've stripped it from the patch and created a new one.
Comment 5 Adam Jackson 2008-02-12 11:46:41 EST
Right you are, the module loader chunk there was included accidentally.

Building this as, update will go out momentarily.
Comment 6 Fedora Update System 2008-02-12 13:08:47 EST
xorg-x11-server- has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-02-13 00:05:49 EST
xorg-x11-server- has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1542
Comment 8 Adam Jackson 2008-02-22 15:13:52 EST
Not a F9 bug, removing from F9 blocker.
Comment 9 Fedora Update System 2008-02-25 19:28:17 EST
xorg-x11-server- has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Christian Krause 2008-02-27 02:19:14 EST
With the latest update the problem is fixed. Thank you very much!

The bug status can now be changed to "RESOLVED CURRENTRELEASE", version:

Note You need to log in before you can comment on or make changes to this bug.