Bug 397571 - Compile with USB_DEVICE_CLASS
Compile with USB_DEVICE_CLASS
Status: CLOSED DUPLICATE of bug 362221
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 21:59 EST by Bojan Smojver
Modified: 2008-01-14 16:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 05:17:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2007-11-23 21:59:38 EST
Description of problem:
See bug #362221 for the problem description. Essentially, files are missing in
/sys and cameras cannot import photos as a result.

Version-Release number of selected component (if applicable):
2.6.23.8-62.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Attach Canon PowerShot A75 or similar.
2. Wait for gphoto2 to come up with errors on import.

  
Actual results:
Device missing, causing gphoto2 failure.

Expected results:
Used to work.

Additional info:
See bug #362221.
Comment 1 Chuck Ebbert 2007-11-26 11:13:04 EST
In CVS
Comment 2 Bojan Smojver 2007-11-29 15:43:47 EST
Any chance we see kernel-2.6.23.9-67.fc8 in updates soon?
Comment 3 Hans de Goede 2008-01-14 05:17:13 EST
Short intro: I'm a Fedora contributer doing some kernel bug triaging.

A kernel with USB_DEVICE_CLASS enabled has been in updates for a while now, not
sure if that completely solves your problem though, so I'm closing this a dupe
of bug 362221.


*** This bug has been marked as a duplicate of 362221 ***
Comment 4 Bojan Smojver 2008-01-14 16:06:38 EST
It doesn't, as I documented in bug #362221.

Note You need to log in before you can comment on or make changes to this bug.