Bug 397581 - Internet Explorer Rendering Issues for content-navigation bar
Internet Explorer Rendering Issues for content-navigation bar
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Máirín Duffy
wes hayutin
:
: 426118 426124 (view as bug list)
Depends On:
Blocks: 248643
  Show dependency treegraph
 
Reported: 2007-11-23 22:24 EST by Máirín Duffy
Modified: 2010-07-29 12:36 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 17:07:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
how the context nav *should* look (firefox ss) (76.42 KB, image/jpeg)
2007-11-23 22:24 EST, Máirín Duffy
no flags Details
how the content nav is broken in ie6 (77.90 KB, image/jpeg)
2007-11-23 22:24 EST, Máirín Duffy
no flags Details
replacement rhn-base.css (671 bytes, text/css)
2007-11-23 22:26 EST, Máirín Duffy
no flags Details
rhn-iecompat.css (216 bytes, text/css)
2007-11-23 22:27 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-11-23 22:24:25 EST
Description of problem:

As reported by a customer, the context nav menu (the up-to 3 level light grey
rounded corner navigation that is attached to objects and appears directly below
H1s in the webui) has some rendering issues.

Attaching screenshots of firefox (how it should look) and IE (where it's broken.)
Comment 1 Máirín Duffy 2007-11-23 22:24:25 EST
Created attachment 267861 [details]
how the context nav *should* look (firefox ss)
Comment 2 Máirín Duffy 2007-11-23 22:24:56 EST
Created attachment 267871 [details]
how the content nav is broken in ie6
Comment 3 Máirín Duffy 2007-11-23 22:26:08 EST
For customers who are experiencing this issue and would like a quick fix, I have
attached two stylesheets. One is new and one is a replacement for an existing one.

Please back up /var/www/html/css/rhn-base.css on your Satellite, and replace it
with the attached rhn-base.css. Also please copy the rhn-iecompat.css file into
/var/www/html/css.
Comment 4 Máirín Duffy 2007-11-23 22:26:38 EST
Created attachment 267881 [details]
replacement rhn-base.css
Comment 5 Máirín Duffy 2007-11-23 22:27:11 EST
Created attachment 267891 [details]
rhn-iecompat.css
Comment 6 Máirín Duffy 2008-01-25 17:20:49 EST
TESTPLAN
=========

In Internet Explorer 6+, visit the configuration channel details page. It should
look as in the screenshot in comment 1, not as in comment 2.
Comment 7 Máirín Duffy 2008-01-25 17:44:46 EST
*** Bug 426118 has been marked as a duplicate of this bug. ***
Comment 8 Máirín Duffy 2008-01-25 17:57:06 EST
*** Bug 426124 has been marked as a duplicate of this bug. ***
Comment 9 Máirín Duffy 2008-01-25 17:58:26 EST
TESTPLAN PART 2
================

Check the screens in bugs 426124, 426118, 426126, and 426119 to make sure they
are also not off.
Comment 10 wes hayutin 2008-02-04 11:06:06 EST
not sure if this made it into the latest build.. doesnt look like it...
Comment 11 wes hayutin 2008-02-05 13:55:01 EST
moving back to on dev
Comment 12 Máirín Duffy 2008-02-05 14:30:09 EST
looks like the rhn-iecompat.css stylesheet was missing. got it in now.

Adding         rhn-iecompat.css
Transmitting file data .
Committed revision 136540.
Comment 13 wes hayutin 2008-02-11 09:53:39 EST
verified build 136
Comment 14 Corey Welton 2008-03-19 10:44:09 EDT
release_pending
Comment 15 Brandon Perkins 2008-04-02 17:07:48 EDT
UI Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.