Bug 3977 - text/html attachment attached as text/plain
Summary: text/html attachment attached as text/plain
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL: http://www.maison-otaku.net/~loki/pat...
Whiteboard:
Keywords:
: 3978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-07-10 10:32 UTC by Traub, JT
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 16:53:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Traub, JT 1999-07-10 10:32:38 UTC
This appears also to be part of a larger problem.  egcs
included with RedHat 6 optimizes a function in such a way
that called from certain places, the return value is
smashed.  This causes Pine to correctly report to the local
user that a file is of one MIME type, but end up attaching
it as the default for the type.  (E.g. text/* becomes
text/plain, etc.)  To reproduce this bug, compile Pine from
the SRPM on RedHat 6 with egcs-1.1.2-13 (RPM, egcs --version
shows 2.91.66).  This bug ALSO occured on a Linux 1.2.x
system using gcc-2.7.2 on RedHat 3.0.3 (just to show it's
apparently a long-standing bug).

Adding a sleep(0) call above the return in the problematic
function is a solution to this problem.  See the attached
URL.

While this should probably be fixed in PINE in the
short-term, long term it probably points to something
needing to be seen to in egcs.  IT IS WORTH NOTING THAT THIS
BUG OCCURED WITH ALL OPTIMIZATIONS OFF.

Comment 1 Traub, JT 1999-07-10 10:36:59 UTC
Egcs counterpart to this bug is #3978

Comment 2 Traub, JT 1999-07-12 17:19:59 UTC
Sorry, I just like being kept in the loop on bugs I report :)

Comment 3 Cristian Gafton 1999-07-15 16:50:59 UTC
*** Bug 3978 has been marked as a duplicate of this bug. ***

This appears also to be part of a larger problem.  egcs
included with RedHat 6 optimizes a function in such a way
that called from certain places, the return value is
smashed.  This causes Pine to correctly report to the local
user that a file is of one MIME type, but end up attaching
it as the default for the type.  (E.g. text/* becomes
text/plain, etc.)  To reproduce this bug, compile Pine from
the SRPM on RedHat 6 with egcs-1.1.2-13 (RPM, egcs --version
shows 2.91.66).  This bug ALSO occured on a Linux 1.2.x
system using gcc-2.7.2 on RedHat 3.0.3 (just to show it's
apparently a long-standing bug).

Adding a sleep(0) call above the return in the problematic
function is a solution to this problem.  See the attached
URL.

While this should probably be fixed in PINE in the
short-term, long term it probably points to something
needing to be seen to in egcs.  IT IS WORTH NOTING THAT THIS
BUG OCCURED WITH ALL OPTIMIZATIONS OFF.  This bug has been
logged against Pine as well.

------- Additional Comments From jtraub@dragoncat.net  07/10/99 06:37 -------
Pine counterpart bug is #3977

Comment 4 Cristian Gafton 1999-07-15 16:53:59 UTC
I managed to attach text/html parts just fine in pine. I guess that
whatever you  are seeing is the normal behavior of pine, which is
trying to do an autotranslation to text/plain for you.

If egcs would have behaved this way a lot of other things will break
badly on the system.


Note You need to log in before you can comment on or make changes to this bug.