Bug 397901 - IRQBALANCE fails everytime a reboot occurs in Fedora 8
IRQBALANCE fails everytime a reboot occurs in Fedora 8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-24 11:39 EST by Scott Griffin
Modified: 2007-12-01 23:34 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.55-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 20:46:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Griffin 2007-11-24 11:39:26 EST
Description of problem:
I am finding the logs on irqbalance however everytime a reboot is initiated it
receives a 'failed' message shutting down.

Version-Release number of selected component (if applicable):
Fedora 8 

How reproducible:
Install Fedora 8 from live CD, copy the image to hard-drive and reboot. Even
after performing updates irqbalance still receives a 'failed' status on shutdown
or reboot.

Steps to Reproduce:
1. Install Fedora 8 Live disk
2. Copy to hard-drive
3. Any time a reboot occurs irqbalance fails on shutting down or rebooting.
  
Actual results:


Expected results:
Irqbalance should come down cleanly with failing.

Additional info:
Please email me at grifs71@yahoo.com - Scott Griffin, I am still investigating
the root cause and logs. I have installed this release on several machines and
received the same results.
Comment 1 Steve Alexander 2007-11-26 11:33:35 EST
This problem also occurs on x86_64 with core2 duo.

Using strace it appears the irqbalance daemon exits after the first 10 second
sample period and irq re-balance.  The last system calls are:
open("/proc/irq/12/smp_affinity", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 3
fstat(3, {st_mode=S_IFREG|0600, st_size=0, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2aaaaaaae000
write(3, "00000001", 8)                 = 8
close(3)                                = 0
munmap(0x2aaaaaaae000, 4096)            = 0
write(1, "IRQ delta is 16077 \n", 20)   = 20
exit_group(0)                           = ?

irqbalance behaves as if the "--oneshot" parameter is set (it is not, tested).
This of course causes the daemon script * lock file problems.
Comment 2 Steve Alexander 2007-11-26 12:42:14 EST
I've just read the source code and the cause is now obvious.
        /* On single core UP systems irqbalance obviously has no work to do */
        if (core_count<2) 
                exit(EXIT_SUCCESS);
        /* On dual core/hyperthreading shared cache systems just do a one shot
setup */
        if (cache_domain_count==1)
                one_shot_mode = 1;

If there is a single cpu irqbalance exits immediately.
If there is a consolidated cache model, then irqbalance performs a "one shot"
re-balance (as on my core2 duo).

Then the daemon process exits, leaving the lock file.
==
The daemon exits as it has no practical work to preform, however the
init.d/irqbalance script has no means of distinguishing the 'clean exit' from
other failure conditions.

Comment 3 Neil Horman 2007-11-26 13:23:24 EST
fixed in 0.55-7.fc8.  Thanks!
Comment 4 Fedora Update System 2007-11-28 20:46:53 EST
irqbalance-0.55-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Scott Griffin 2007-12-01 23:34:52 EST
I have updated my Fedora 8 machines this update appears to have resolved this issue.

Thank you,
Scott Griffin


[scottg@FEDORA ~]$ rpm -q irqbalance
irqbalance-0.55-7.fc8

Note You need to log in before you can comment on or make changes to this bug.