Bug 39807 - KDE compiled with default set for A4 paper
Summary: KDE compiled with default set for A4 paper
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-09 05:34 UTC by j. alan eldridge
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 08:42:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description j. alan eldridge 2001-05-09 05:34:23 UTC
Description of Problem:

The default paper size for the print dialogs (which I guess might live in 
KDE2LIBS) is set for A4. If this was a setting that was saved in a config 
file, I'd say "No big deal." But, AFAIK, it isn't. So every time you use 
a KDE app for printing you have to switch the paper size.

How Reproducible:

Start up a KDE app. Select File|Print.

Additional Information:

I've run several KDE apps under strace, and grepped the while friggin' 
world, to see if I could find a place that the setting is saved. It 
appears to be compiled into the .so that presents the print dialog, and 
it isn't saved when you exit an app. Bleah.

I set the severity at "high" because this is (a) stupid and (b) really 
really really fscking annoying after a while.

Comment 1 Bernhard Rosenkraenzer 2001-05-09 08:42:38 UTC
This is configurable in KDE 2.2.* - aside from that, setting the default to A4 
is not "stupid". A4 paper is used everywhere in Europe (and you probably agree 
that there's a world outside the US).



Note You need to log in before you can comment on or make changes to this bug.