This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 39808 - spurious 8259A interrupt: IRQ7 on Dell Inspiron 5000e after BIOS A06 Update
spurious 8259A interrupt: IRQ7 on Dell Inspiron 5000e after BIOS A06 Update
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 01:48 EDT by Jan Labanowski
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Labanowski 2001-05-09 01:48:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
I am using Dell Inspiron 5000e. I have both windows and RedHat 7.1 linux on
it.
I upgraded my BIOS with the latest greatest (?) release of BIOS A06 from
Dell support site. And then my problem started. From what I see, Winodows
works fine. But Linux does not. I reinstalled linux after BIOS upgrade, but
it did not help. The symptoms are that my keyboard often freezes totally.
There is nothing I can type, CTL/ALT/DEL does not work either.
The only way to avoid brutal power down with the button is to do
Fn/Suspend, and then push the power button to wake it up. But then
it freezes again.
I get it both on the console, and also after I start
KDE. The mouse work, other things seem to work, but the keyboard is hosed
down.
While I cannot be 100% sure, it seems like I got this behaviour after
upgrading the BIOS to A06. I did everything by the book, and beside...
I do not have this problem with Windows 98 SE which came installed with
my Dell.


How reproducible:
Always

Steps to Reproduce:
1. Boot
2. Type four (4) characters
3.  Fn/Suspend --> Power
4. Type four (4) characters
  etc

	

Actual Results:  got res[1800:187f] for resource 0 of PCI device 115d:0003
got res[10800800:108007ff] for resource 1 of PCI device 115d:0003
got res[10800800:10800fff] for resource 2 of PCI device 115d:0003
got res[10400000:10403fff] for resource 6 of PCI device 115d:0003
PCI: Enabling device 02.00.0 (0000 -> 0003)
got res[1880:1887] for resource 0 of PCI device 115d:0103
got res[10801000:108017ff] for resource 1 of PCI device 115d:0003
got res[10801000:10801fff] for resource 2 of PCI device 115d:0003
got res[10404000:10407fff] for resource 6 of PCI device 115d:0003
PCI Enabling device 02.00.1 (0000 -> 0003)
PCI Setting latency timer of device 02.00.0 to 64
spurious 8259A interrupt: IRQ7




Expected Results:  Normal typing...

Additional info:

The problem was quite reproducible. It gets me both in the console mode
and in the KDE X-window mode. After typing 4 (four) characters
my keyboard was frozed, and I had to do Fn/Suspend->Power dance to type
next four characters. A lot of work to type: "shut" "down" " -h " "now"
This is what spews to the console.


Below are few thinsg about this which I found on the WEB. I do not even
try to understand it.

http://support.intel.com/support/controllers/peripheral/7507.htm
http://www.mail-archive.com/linux-hardware@senator-bedfellow.mit.edu/msg02524.h\tml
http://faqs.jmas.co.jp/FAQs/386bsd-faq/part4

In the last document I found:
        In spite of the number of times this has come up (and people have
        even referenced this section) there are still at least two
        questions on the net about this.  A memorable one was a guy who
        was just vehement that the stray int 7 was what was keeping his
        system from booting.  In fact, he went so far as to say that this
       document was practically worthless because I didn't tell him how
        to fix it.  Of course, once he configured his hard drive controller
        so that it was on the right interrupt, his booting problem went
	away.  I have said it before and I will say it again.  For MOST
	users they do not pose a real threat to your operations.
        I have heard of three people (out of at least 2000) that have
        actually have problems so bad that they couldn't proceed.  They
	bought new computers, and the problem went away.

        These stray interrupts are caused by something in the PC.
        I have yet to see a convincing explanation of precisely what,
        but they are definitely caused by something.  There are four
	ways to deal with this problem.

        1)  Ignore them.  They are spurious and do not effect the
        operation of your computer.

        2)  Implement the lpt driver.  This way, the driver traps
        (the lpt driver expects IRQ 7) and then quietly discards them.
        That is why when folks implement the lpt driver the 'problem'
        goes away.  The computer is taught how to ignore them.

	3)  Do what the original 386bsd code did.  Comment out the
	diagnostic and associated code that tries to deal with them so
        you don't see the error message.

	4)  Buy a new computer that doesn't cause this problem.   It is a
	known hardware problem with the 8259 being reset incorrectly in
        hardware.

=============

I do not want to buy the new computer, and I therefore I installed the
printer driver on my laptop (though I do not have any printer attached)
and this HELPED. I could say that problem is solved. But is it?

Jan
Comment 1 Jan Labanowski 2001-05-09 02:56:46 EDT
Actually adding a printer to serve IRQ7 helped only initially. 
Then, after reboot, I got back to square 1. I am sorry if I will
make you angry... But As you may notice I am writing this comment from
within W98SE. Windows work without problems...
Comment 2 Jan Labanowski 2001-05-10 12:38:25 EDT
I found a way around it. I was using the serial mouse (generic 3 button in the
Mouse Systems
mode configured by mouseconfig) on the 9pin port. When I removed the serial
mouse and used 
the PS/2 on the mini-din port, the laptop was working (though the spurious
interrupt was still
there on boot). In short, after upgrading the Bios to A6, you cannot use serial
mouse with the
Dell 5000e under Linux (but it works under Win98SE).
Comment 3 Sammy 2001-05-10 17:47:04 EDT
I always get the spurious interrupt message and couple of other messages
that indicate that more than one device is usiing the same irq. Only on ,my
Dell inspiron 4000 (none on my desktop).

However, these messages don't seem to cause any problem for me. So,
I actually rebuild the kernel and comment those print lines in the kernel
source.....not a good practice but I do not like to see error messages mixed
in my boot messages while everything is fine.
Comment 4 giuseppe.angilella 2004-01-05 04:22:32 EST
I get the same error message on tty1 and /var/log/messages on my
laptop, running linux RedHat 9.0. The problem is not reproducible,
i.e. it happens randomly, but when it happens either the system slows
down and ventually freezes, or the sound card does not work, or the
network card stops working after a while ... I gather it is connected
with the way the operating system and/or the BIOS assign IRQ numbers
to the various devices. This is a dynamic process, as far as I
understand, which can give different results at each reboot. (And
therefore problems with different devices each time.) It may be
kindled or fixed by rebooting linux after a windows session, since
windows sets IRQs of its own. I am told that some BIOSes allow setting
static IRQs (??) of their own, but mine doesn't. I can only choose
among the options "yes/no/auto" for plug'n'play. If I got it wrong or
some more help is available, please, tell me!
Comment 5 Bugzilla owner 2004-09-30 11:38:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.