Bug 3981 - Bug 3360 all over again. (raidadd being used without raidstart)
Bug 3360 all over again. (raidadd being used without raidstart)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-10 14:04 EDT by Jay Freeman
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 12:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Freeman 1999-07-10 14:04:20 EDT
Why can't we just do something like this (diff from
initscripts-4.24-1):

267,269c267,271
< # Add raid devices, old style...
< if [ -f /proc/mdstat -a -f /etc/raidtab -a -
x /sbin/raidadd ]; then
<       action "Starting up RAID devices" raidadd -a
---
> # Add/Start raid devices
> if [ -f /proc/mdstat -a -f /etc/raidtab ]; then
>       rc=0
>       if [ -x /sbin/raidadd ]; then
>               action "Starting up RAID devices" raidadd -a
271c273
<       rc=$?
---
>               rc=$?
273,274c275,280
<       if [ $rc = 0 ]; then
<               raidrun -a
---
>               if [ $rc = 0 ]; then
>                       raidrun -a
>                       rc=$?
>               fi
>       elif [ -x /sbin/raidstart ]; then
>               action "Starting up RAID devices"
raidstart -a

That should work for everyone.  What's really strange about
how the latest initscripts are dealing with raid is that it
doesn't even match with the version of raidtools that is
installed with the system.  After bug 3360 I wasn't
expecting this to be a problem anymore so I stopped
checking the rc.sysinit to see if it had a raidstart in it,
freaked when I couldn't boot up :).  (btw, there should be
a page showing correct usage of the bug system so that
people like me know whether we should file a new bug or
simply attach things to the end of other ones (since we
can't reopen bugs we don't own...))
Comment 1 Bill Nottingham 1999-07-12 12:21:59 EDT
FWIW, unified diffs have the advantage of being more human legible,
as well as being much more amenable to being extracted from the
HTML page.

The code in rc.sysinit is for backwards compatibility only; if
you have the old-style raid partitions, it's used, in which
case you need the old raid tools anyways. If you have the new-style
raid, it should be autostarted...
Comment 2 Jay Freeman 1999-07-12 12:39:59 EDT
The RAID partitions are only autodetected if you specified:
  persistent-superblock 1
:in your raidtab file when you created the raid set.  If you did not,
then they must be manually started by reading from the raidtab file.
You also have to make the partition id's for the drives 0xFD
(something I didn't know until today when I went researching to see
if there was something I missed, thanks :) ).  BUT, it is of course
possible that people might not have flaged their RAID drives with the
persistant superblock when they created them which would require them
to recreate them in order to have autodetection work.
Comment 3 Cristian Gafton 1999-07-15 12:46:59 EDT
We will only support the raid devices that were created with the
autodetection enabled. If you do it any other way, you are on your
own.

This is the path that the RAID code is envolving anyway.

Note You need to log in before you can comment on or make changes to this bug.