Bug 398421 - Data Corruption on NFS mounted filesystems
Data Corruption on NFS mounted filesystems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 10:50 EST by Rolf Fokkens
Modified: 2007-12-07 18:33 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.8-34.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 18:33:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2007-11-25 10:50:18 EST
Description of problem:
Data Corruption on NFS4 mounted filesystems

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-21.fc7

How reproducible:
100%

Steps to Reproduce:
1. start gimp and make a complex multi layer image
2. save as xcf
3. open the xcf
4. Gimp error: XCF: This file is corrupt!  I have loaded as much
of it as I can, but it is incomplete.
  
Actual results:
XCF: This file is corrupt!  I have loaded as much of it as I can, but it is
incomplete.

Expected results:
Gimp operating on the opened file

Additional info:
Known kernel bug:
http://www.nabble.com/Not-saving-resolution-information---%22XCF:-This-file-is-corrupt!%22-t4760083.html
http://bugzilla.kernel.org/show_bug.cgi?id=9315
Comment 1 Chuck Ebbert 2007-11-26 19:53:16 EST
kernel-2.6.23.8-34.fc7 is in updates-testing with this fix applied.

You can update with:

 # yum --enablerepo=updates-testing update kernel
Comment 2 Rolf Fokkens 2007-11-28 14:23:33 EST
Problem seems to be solved this way.
Comment 3 Ade Rixon 2007-11-30 02:53:13 EST
The bug title is slightly misleading; I'm seeing this with NFS v3 as well. It
affects LightZone 2.4 for Linux when exporting TIFF files (the files are
unreadable by libtiff-enabled applications due to "zero scanline size").
Comment 4 Alexandre Oliva 2007-12-03 00:15:50 EST
Any idea of how much longer this data-corruption problem explicitly fixed in the
Fedora 8 kernel (on Nov 7), commonly exercised by backup programs (rsync -S) on
commonly-used filesystem types (nfs) going to remain in the most up-to-date
stable kernel available for Fedora 7?
Comment 5 Chuck Ebbert 2007-12-04 13:57:26 EST
2.6.23.8-34 is being released ASAP.
It has been available in updates-testing for over a week...

Note You need to log in before you can comment on or make changes to this bug.