Bug 398521 - drop the metacity requires?
drop the metacity requires?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nodoka-theme-gnome (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-25 13:07 EST by Patrice Dumas
Modified: 2009-09-21 17:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 04:31:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2007-11-25 13:07:29 EST
Description of problem:

Why does this them requires metacity? This is also used
by other things that metacity and prevents metacity
from being removed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Sourada 2007-11-25 16:54:08 EST
Logically, a theme for window manager is useless without the window
manager, other way around it works, as window manager should have some
fallback theme which works even without any other themes installed. If
something other than meta-theme or meta-package depends on a window
manager theme, it is IMHO wrong. The removal of metacity dependency from
nodoka-metacity-theme is justified only if there is such a policy or another
strong (and logical) reason.
Comment 2 Patrice Dumas 2007-11-25 18:08:37 EST
this theme is certainly useful without the window manager
since nodoka-theme-gnome and  fedora-gnome-theme and
even (indirectly) the whole gnome stack depends on it. Or the
dependency on this package is buggy.
Comment 3 Matthias Clasen 2008-04-28 10:19:33 EDT
Fwiw, dropping the dependency seems harmless. 
Comment 4 Martin Sourada 2008-04-28 11:40:22 EDT
It is harmless but I am not happy about removing a dependency on a package that
makes this one useful... Although, I don't see any explicit guidelines about
this particular case in the packaging guidelines, so I'll probably go with it
and drop the dependency.
Comment 5 Patrice Dumas 2008-04-28 13:22:10 EDT
There isn't everything in the packaging guidelines. Especially when
there are cases where things make sense and other when it doesn't. 

In this case, for example, things are not obvious, since the dependency
on metacity is not wrong. If nodoka-theme-gnome wasn't needed by the 
whole gnome stack, it would haven't been an issue. Still not having
the dependency is also not wrong, for example there could be other themes
and it could be up to the user to choose, and also metacity could be usable
without a theme. All in all you have to weight all those issues and 
take into consideration distribution-wide issues, in that case the dependency
from all gnome packages on metacity. 

Alternatively, you can coordinate with packagers of other packages on
the way to libgnome to cut the dependency chain elsewhere:

metacity - nodoka-theme-gnome - fedora-gnome-theme - libgnome
Comment 6 Bug Zapper 2008-05-13 23:59:27 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Martin Sourada 2008-05-30 04:31:16 EDT
I finally decided to remove the metacity dependency. The fixed package is in
rawhide.

Note You need to log in before you can comment on or make changes to this bug.