Bug 39884 - up2date cannot handle multiple versions of the same package
up2date cannot handle multiple versions of the same package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 11:39 EDT by Stephen Tweedie
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-28 11:38:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2001-05-09 11:39:09 EDT
I have the libxml package from seawolf, libxml-1.8.10-1, installed.  I have
also installed a libxml-2 package, libxml-2.0.0-1. The two do not overlap
(they use different .so names) and "rpm -V" verifies that both are intact.

However, up2date-gnome insists on trying to pull down the libxml-1.8.10-1
package now.  up2date offers it as a "package available for update",
despite the fact that it is already installed.  Trying to proceed with the
upgrade fails with the error that the package is already installed.

This is 100% reproducible.


Offering to download already-installed packages, then complaining because
they are already present, is probably not the best way to deal with
multiply-versioned rpms.
Comment 1 Adrian Likins 2001-05-09 12:01:32 EDT
looks like the computation to figure out which of the installed
packages is newer isnt considering epoch, but the code to
determine if a package needs an update is using it.

The packages question are:

libxml-2.0.0-1-i386  (no epoch)

libxml-1.8.10-1.i386 (epoch of 1)

So up2date thinks libxml-2 is the newest installed, but that
libxml-1.8 is "newer", and trying to install it. 

working on a fix...
Comment 2 Greg DeKoenigsberg 2002-04-28 11:38:13 EDT
Is this a crufty bug?  Can it be retired?
Comment 3 Adrian Likins 2002-05-15 16:58:42 EDT
yeah, crufty bug, long since fixed.

Note You need to log in before you can comment on or make changes to this bug.