Bug 399131 - alert count 1
alert count 1
Status: CLOSED DUPLICATE of bug 312191
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
: 399151 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-11-26 02:08 EST by Robert McLachlan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-26 11:00:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert McLachlan 2007-11-26 02:08:07 EST
Description of problem: I was going from 1 web page to another and it popped up.

Version-Release number of selected component (if applicable):

How reproducible:
moving in and out from different web pages.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

    SELinux is preventing /sbin/modprobe (insmod_t) "read write" to
    socket:[15040] (iptables_t).

Detailed Description
    SELinux denied access requested by /sbin/modprobe. It is not expected that
    this access is required by /sbin/modprobe and this access may signal an
    intrusion attempt. It is also possible that the specific version or
    configuration of the application is causing it to require additional access.

Allowing Access
    You can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                user_u:system_r:insmod_t
Target Context                user_u:system_r:iptables_t
Target Objects                socket:[15040] [ rawip_socket ]
Affected RPM Packages         module-init-tools-3.3-0.pre11.1.0.fc7
Policy RPM                    selinux-policy-2.6.4-57.fc7
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   plugins.catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain #1 SMP
                              Thu Nov 1 21:09:24 EDT 2007 i686 i686
Alert Count                   1
First Seen                    Sat 24 Nov 2007 09:43:01 PM PST
Last Seen                     Sat 24 Nov 2007 09:43:01 PM PST
Local ID                      464d1ad0-0488-4fed-8ab9-d07bbf3cb757
Line Numbers                  

Raw Audit Messages            

avc: denied { read, write } for comm="modprobe" dev=sockfs egid=0 euid=0
exe="/sbin/modprobe" exit=0 fsgid=0 fsuid=0 gid=0 items=0 path="socket:[15040]"
pid=3312 scontext=user_u:system_r:insmod_t:s0 sgid=0
subj=user_u:system_r:insmod_t:s0 suid=0 tclass=rawip_socket
tcontext=user_u:system_r:iptables_t:s0 tty=pts0 uid=0
Comment 1 Daniel Walsh 2007-11-26 10:27:06 EST
Leaked file descriptor.  

All file descriptors should be closed on exec

fcntl(fd, F_SETFL, F_CLOEXEC)

Comment 2 Thomas Woerner 2007-11-26 10:56:53 EST
*** Bug 399151 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Woerner 2007-11-26 11:00:29 EST

*** This bug has been marked as a duplicate of 312191 ***

Note You need to log in before you can comment on or make changes to this bug.