Bug 39924 - Fdomain/Adaptec 292 driver does not share IRQs
Fdomain/Adaptec 292 driver does not share IRQs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 14:10 EDT by Jeremie Lacasse
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 08:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the lspci - v that you ask to me (3.12 KB, text/plain)
2001-05-09 15:37 EDT, Jeremie Lacasse
no flags Details
This is the file in an ascii file (3.51 KB, text/plain)
2001-05-10 08:23 EDT, Jeremie Lacasse
no flags Details

  None (edit)
Description Jeremie Lacasse 2001-05-09 14:10:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
My ethernet card and my scsi card can't have the same IRQ. I had to 
manually distribute IRQs among the PCI slots to be sure that the two card 
have a different IRQ. It seems that this kernel (2.4) doesn't support IRQ 
sharing, because with the same configuration with Red hat 7 (kernel 2.2) 
it work properly.
I'am not sure but, if someone have an idea about my trouble please send my 
a mail.
thank you 

How reproducible:
Always

Steps to Reproduce:
1.have the same IRQ for a ethernet card and a scsi card
2.try with ifconfig to bring up the ethernet adaptor

4.manually give different IRQ
5.and after that the two adaptor will work properly
	

Actual Results:  the os will tell you: resource busy
and you cannot use yours ethernet card

Additional info:

Manually give different IRQ
and after that the two adaptor will work properly
Comment 1 Jeremie Lacasse 2001-05-09 15:05:19 EDT
I forgot my scsi card is adaptec 2920
and my ethernet card is a 82559ER
I try with other scsi card and the bug don't reappear.
Comment 2 Arjan van de Ven 2001-05-09 15:17:57 EDT
Can you attach the output of "lspci -v" so we know exactly which devices we're
talking about ?
Comment 3 Jeremie Lacasse 2001-05-09 15:37:18 EDT
Created attachment 17927 [details]
this is the lspci - v that you ask to me
Comment 4 Arjan van de Ven 2001-05-09 15:59:17 EDT
Could you please send it as ascii not as kword ?
Comment 5 Jeremie Lacasse 2001-05-10 08:23:49 EDT
Created attachment 17986 [details]
This is the file in an ascii file
Comment 6 Alan Cox 2001-05-19 15:26:25 EDT
Known problem with the fdomain driver. Unfortunately its an ancient card that we
don't really have enough information about. 

Doug - if you can ping Justin Gibbs/Adaptec and get me the 'how to test for the
IRQ source being this card' instructions then I can fix this driver
Comment 7 Alan Cox 2003-06-06 08:26:02 EDT
Was finally fixed in mid 2.4

Note You need to log in before you can comment on or make changes to this bug.