Bug 39925 - 3 ati 128 mobility problems related to nonnative screen resolutions and DPMS
3 ati 128 mobility problems related to nonnative screen resolutions and DPMS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 14:24 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version: RHL 7.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 19:58:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my config file (3.71 KB, text/plain)
2001-05-24 17:44 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-05-09 14:24:02 EDT
Description of Problem: r128 mobility problems : 1) r128 mobility card does not 
work in 24 bit mode on anything other than native resolutions (1400x1050 on 
dell5000e) 2) At 16/8 bit mode exitting X at any resolution other than native 
causes system to hang and need a hardreboot 

These seems to be reproduced here :

http://ibgwww.colorado.edu/~lessem/5000e/

3) DPMS seems to hang system on a resume after suspending.

How Reproducible:


Steps to Reproduce:
1.  Set resolution to 800x600 
2.  start X
3.  exit X

Actual Results:
  Freeze

Expected Results:

  No Freeze
Additional Information:
Comment 1 Mike A. Harris 2001-05-10 13:54:21 EDT
I'm assuming that you accidentally chose Red Hat Linux 4.2.. because it is
no longer supported.  If you are in fact using Red Hat Linux 4.2.  Please
upgrade to Red Hat Linux 7.1 for the best support.  If it isn't 4.2, please
update the bug report to indicate the proper release.

Also attach your X logs, and configuration files using the link below.

What version of XFree86 are you using?
Comment 2 Mike A. Harris 2001-05-24 00:54:28 EDT
Closing bug because of lack of response, assuming the bug report is filed
against 4.2 as specified - which is unsupported.  I don't believe r128 is
supported in 4.2 either.
Comment 3 Need Real Name 2001-05-24 17:44:41 EDT
Created attachment 19555 [details]
my config file
Comment 4 Need Real Name 2001-05-24 17:48:16 EDT
Hi apologies for getting taking so long to get back to you.. I've had various
amounts of success upgrading a few components. Issue (2) The crash on exitting
out of X at lower resolutions has been resolved w/ your latest beta (from 14 on
at least). One more issue that I forgot to mention is actually fixed with the
latest stable DRI from sourceforge. W/ a whole slew of the ati cards (perfect*
ati mobility 128 ), there is a "flickering" issue that can only be resolved by
either turning DRI off or toggling UseCCEfor2D. Upgrading DRI to 0.7 seemed to
fix this problem. Issue (1) still doesn't work, but this is apparantly a current
limitation of X/r128 and may be fixed sometime in the future.
Comment 5 Mike A. Harris 2001-11-06 08:46:34 EST
I believe this issue to be resolved now in Red Hat Linux 7.2 with
XFree86 4.1.0-3.  Could you confirm if the new X fixes this for you?

Note You need to log in before you can comment on or make changes to this bug.