Bug 39928 - Requirement for initscript and filesystem versions appears too restrictive
Requirement for initscript and filesystem versions appears too restrictive
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
6.1
All Linux
low Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 15:00 EDT by kenneth_porter
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 15:00:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kenneth_porter 2001-05-09 15:00:11 EDT
Rebuilding xinetd-2.1.8.9pre14-6.src.rpm on RH6.1, resulting package can't be installed without --nodeps. Installation appears to work correctly. 

I can't identify a reason for the package requirements for specific initscript and filesystem versions. The initscript requirement is particularly 
troublesome as it imposes a requirement for a 2.4 kernel.

If the specific versions of initscripts and filesystem are really needed, please add a comment in the spec file explaining why.
Comment 1 Trond Eivind Glomsrxd 2001-05-09 17:32:15 EDT
The reason for the required version of initscripts is the translation mechanism,
the reason for the required version of filesystem is the dependance on
/etc/xinetd.d.

The reason for the filesystem was given in the changelog, while the initscripts
goes under "gettextization" (which could have clearer).

Note You need to log in before you can comment on or make changes to this bug.