This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 399291 - "option space agent does not exist, but is configured"
"option space agent does not exist, but is configured"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 05:12 EST by Jonathan Kamens
Modified: 2008-07-01 22:27 EDT (History)
0 users

See Also:
Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 22:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-11-26 05:12:36 EST
Since upgrading to dhclient 3.1.0-8.fc9, I get this in my syslog when dhclient
renews my lease:

option_space_encapsulate: option space agent does not exist, but is configured.

I've tried to figure out what this means, but I haven't been able to figure it
out.  It seems like something is wrong that is prompting this message, but note
that my lease is working just fine nevertheless.
Comment 1 Bug Zapper 2008-05-13 23:59:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 David Cantrell 2008-07-01 22:26:44 EDT
Fedora 9?  I have dhcp-4.0.0 in F-9, so you shouldn't even be seeing these messages anymore.  There 
was a bug in the dhcp-3.y.z option handling code that would cause the option space agent bit to run 
always.  The message you see is harmless, but it's been fixed in dhcp-4.0.0.

So, my question is are you running Fedora 9 or something else?  Because I didn't include dhcp-3.1.0 in F-
9.
Comment 3 David Cantrell 2008-07-01 22:27:44 EDT
Oh, crap.  I see what happened.  Argh, bug triage group messing up my tracking system.

OK, so, this bug should be fixed as of Fedora 9.  Ignore comment #2.

Note You need to log in before you can comment on or make changes to this bug.