Bug 399321 - sos does not warn if invalid plugins are passed to -n/--skip-plugins
Summary: sos does not warn if invalid plugins are passed to -n/--skip-plugins
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sos
Version: 4.6
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact:
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 443397
TreeView+ depends on / blocked
 
Reported: 2007-11-26 10:47 UTC by Bryn M. Reeves
Modified: 2018-10-19 21:34 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-07-24 19:30:50 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0663 normal SHIPPED_LIVE sos bug fix and enhancement update 2008-07-23 15:35:35 UTC

Description Bryn M. Reeves 2007-11-26 10:47:28 UTC
Description of problem:
Users of the legacy sysreport tool often wanted to disable "rpm -Va" data
gathering due to the amount of time it consumes. The "-norpm" option was
provided to allow this.

This option has been removed from sosreport in favour of the plugin interface,
e.g. "sysreport -norpm" now becomes "sosreport -k rpm.rpmva=off".

The sosreport tool now also accepts a list of plugins to disable via the
-n/--skip-plugins options. If a user is unaware of this and passes "-norpm"
sosreport skips the non-existant "orpm" plugin and does not alert the user to
the fact they have passed an invalid option.

For users transitioning from sysreport this is confusing. It would be preferable
to emit either a general warning about a non-existant plugin or special-case the
legacy sysreport options (-norpm seems to be the only one that could cause
confusion as sysreport does not currently use -d (-dmidecode in sysreport)).

Version-Release number of selected component (if applicable):
sos-1.7-6.1

How reproducible:
100%

Steps to Reproduce:
1. # sosreport -norpm
2. ps ax | grep rpm

  
Actual results:
See sosreport running "rpm -Va"

Expected results:
A warning that the -norpm option from sysreport is not supported in sosreport.

Additional info:

Comment 2 Navid Sheikhol-Eslami 2007-12-10 10:42:09 UTC
Fixed in upstream repository. Thanks.

-- Navid

Comment 19 errata-xmlrpc 2008-07-24 19:30:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0663.html


Note You need to log in before you can comment on or make changes to this bug.