Bug 3996 - rpm --rebuilddb creates files with current umask
rpm --rebuilddb creates files with current umask
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-12 02:40 EDT by v.kuhlmann
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-16 15:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description v.kuhlmann 1999-07-12 02:40:01 EDT
I just installed the updated rpm-3.0.2-6.0, and did a
--rebuilddb (although strictly not necessary). It turns out
that the files under /var/lib/rpm are recreated with the
current umask of root, i.e. 600. (I anyway run root with
umask 077)

This should not be the case. THese files should always get
644.
Comment 1 Jay Turner 1999-07-12 10:56:59 EDT
Indeed the files in /var/lib/rpm get written with root's umask, so in
the case of a 077 umask, all of the files are getting written RW for
root only.  Not sure whether this is a problem or not, but have
forwarded it to a developer for further action.
Comment 2 Jeff Johnson 1999-08-16 15:09:59 EDT
Unset umask before rebuilding the database. There's no way that
rpm can identify that /var/lib/rpm/* should be mode 0644 or mode 0600.

Note You need to log in before you can comment on or make changes to this bug.