Bug 399761 - stl import files not included
stl import files not included
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gsoap (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Farrellee
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 13:08 EST by K H
Modified: 2008-02-08 16:36 EST (History)
0 users

See Also:
Fixed In Version: gsoap-2.7.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 16:36:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description K H 2007-11-26 13:08:03 EST
Description of problem:
stl.h, stldeque.h, stllist.h, stlset.h, stlvector.h from soapcpp2/import are not
included in rpm file

Version-Release number of selected component (if applicable):
gsoap-2.7.9-0.1.l

How reproducible: 100%


Steps to Reproduce:
pass a file to soapcpp2 that contains

#import "stlvector.h"
  
Actual results:
Can't file file stlvector.h

Expected results:
Should be able to find the file but its not installed in the rpm

Additional info:
Please include stl.h  stldeque.h  stllist.h  stlset.h  stlvector.h from
soapcpp2/import in the gsoap sources in the rpm.  

When I was building my own gsoap rpm's, I installed them in /usr/include/gsoap
by adding a line:
cp soapcpp2/import/*stl*.h $RPM_BUILD_ROOT%{prefix}/include/gsoap/

after 
make install

in the %install section
Comment 1 Matthew Farrellee 2007-11-26 15:12:47 EST
I have updated the spec to place the soapcpp2/import/*.h header files into
/usr/include/gsoap. You'll have to use -I/usr/include/gsoap when you run
soapcpp2. This change will be available in 2.7.9-0.2.l.
Comment 2 Fedora Update System 2007-11-28 20:36:56 EST
gsoap-2.7.9-0.2.l has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gsoap'
Comment 3 Matthew Farrellee 2007-11-29 01:57:19 EST
There is a better solution to this bug, which is to put soapcpp2/import/*.h into
/usr/share, because they really are not C/++ header files. They are headers only
soapcpp2 can read and process. This means using -I/usr/share/gsoap/import, which
is what I'll make 2.7.9-0.3.l do, and hopefully -0.2.l will be skipped.
Comment 4 Fedora Update System 2007-12-03 06:41:57 EST
gsoap-2.7.9-0.3.l has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gsoap'

Note You need to log in before you can comment on or make changes to this bug.