Bug 39984 - "An internal error occurred in the installation program"
"An internal error occurred in the installation program"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-09 21:57 EDT by divy
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 10:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description divy 2001-05-09 21:57:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
I tried to do a fresh install on a SuperMicro s2dge (dual PII 400 xeon) with Adaptec 2940 (all scsi), matrox G400, intel eepro 100.  The 1st try 
hung about half way through (I went to bed with 4 hours to go, and the exact same time done & to go (and item) were there the next morning).  
So I disabled the cache & tried again on my way out the door to work, and when I got home I found a box on the screen with the summary 
message, and this:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 520, in ?
    intf.run(todo, test = test)
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1965, in doInstall
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1656, in writeConfiguration
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 863, in writeNetworkConfig
  File "/usr/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 173, in lookupHostname
IOError: (Errno 28) No space left on device

This install was from a downloaded copy on /dev/sdb, and /dev/sda is a new 18g drive with 1g swap, 200m /var, 8g /usr & the rest in /.

Please email if I can answer more questions,
Dan

How reproducible:
Always (twice anyway)

Steps to Reproduce:
1.boot from floppy
2.tell it the image is on hd, in /dev/sdb1
3.wait hours & get the message found above
	

Actual Results:  got little box with info listed above

Expected Results:  System installs, I log in, Oh Happy Day.

Additional info:
Comment 1 Brent Fox 2001-05-10 16:40:44 EDT
Was there any more to the error message?  Usually there's a bit more information
about the contents of the variables inside the function that the crash occured in.

Also, when the machine is in the crashed state, can you go to VC2, type 'df',
and post the output of that here?
Comment 2 divy 2001-05-11 21:19:27 EDT
Hey,

Well I've tried 3 times now, and even though I still have the cache disabled, the install just hangs (each time at a different package).  I switched to the 
shell, and / is full (2289 out of 2289 used), but the rest still have room.  I've downloaded a bootnet image, so I'll have a go at that...

Any other info that might be helpful?  And thanks for the response!
Dan
Comment 3 divy 2001-05-12 06:47:11 EDT
Success!  - I started the install again last night, and this morning it's in the "An internal
error..." state.  There isn't any additional text in the error message beyond the bit about
letting redhat know by opening a bug.  And when I do the df:

Mount Point                               1k blocks    Used        Available
/                                                2289           2289        0
/proc                                          0                0             0
/dev/pts                                      0                0             0
/mnt/runtime                               3191           2409        702
/mnt/runtime/usr                          4459          4027        432
/mnt/sysimage                            10151832   874928     9276904
/mnt/sysimage/boot                     54416        7167        47249
/mnt/sysimage/proc                     0               0              0
Comment 4 Brent Fox 2001-05-14 18:30:34 EDT
Hmm..weird.  How much RAM do you have?  If you go to VC2 and type 'cat
/proc/meminfo', what does it say?  Is that the correct amount of ram in the
system?  Also, if you boot with 'linux ide=nodma', does that help?

Also, go to VC2 and say 'ls -l /tmp/syslog'?  What is the output of that? 
There's the chance that the kernel is having some sort of timeout errors with
the SCSI drivers and the syslog is filling up the / filesystem.  

Also, something weird is that we usually mount a 4 MB ramdisk, and that is what
the / partition is during the install environment.  For example, when I do df on
my test machine, I get:

Mount Point                               1k blocks    Used        Available
/                                         4030         1007        3023

for the / partition.  Yours is only 2289k in size...this strikes me as very strange.

Comment 5 divy 2001-05-16 05:36:34 EDT
There's 512M of memory in the system, and the /proc/meminfo looks correct.  From the 
boot floppy I wasn't able to add any arguments (like the ide=nodma) - it complained.  Is 
there a way to do that?  The size of the /tmp/syslog is 8811.

The network install via ftp didn't work - I started it Sat around 9a, and by noon Sun it still
had more to go then it had done (and a check of the log said that there was only one file
it had to retry).  I live off a 512k dsl connection...

I've downloaded a new copy of the iso images, rewritten the boot diskette & am having 
another go...
Comment 6 Brent Fox 2001-05-16 16:52:58 EDT
If you are still having problems with the new cd's, give this a try.  Try
booting with 'linux ide=nodma' at the boot prompt.  Does that help?
Comment 7 Brent Fox 2001-05-29 10:20:27 EDT
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.