Bug 400071 - Iotop doesn't work with xterm-color
Summary: Iotop doesn't work with xterm-color
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iotop   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-26 20:18 UTC by Ruben Kerkhof
Modified: 2008-01-15 22:57 UTC (History)
2 users (show)

Fixed In Version: 0.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 22:53:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ruben Kerkhof 2007-11-26 20:18:35 UTC
Description of problem:

[ruben@odin F-8]$ iotop
Traceback (most recent call last):
  File "/usr/bin/iotop", line 608, in <module>
    main()
  File "/usr/bin/iotop", line 604, in main
    curses.wrapper(run_iotop, options)
  File "/usr/lib/python2.5/curses/wrapper.py", line 44, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/bin/iotop", line 562, in run_iotop
    ui = IOTopUI(win, process_list, options)
  File "/usr/bin/iotop", line 445, in __init__
    curses.curs_set(0)
_curses.error: curs_set() returned ERR

Version-Release number of selected component (if applicable):
iotop-0.1-1.fc8

How reproducible:
export TERM=xterm-color
iotop

  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/iotop", line 608, in <module>
    main()
  File "/usr/bin/iotop", line 604, in main
    curses.wrapper(run_iotop, options)
  File "/usr/lib/python2.5/curses/wrapper.py", line 44, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/bin/iotop", line 562, in run_iotop
    ui = IOTopUI(win, process_list, options)
  File "/usr/bin/iotop", line 445, in __init__
    curses.curs_set(0)
_curses.error: curs_set() returned ERR

Expected results:

normal iotop output.

Additional info:

iotop works fine with normal xterm.
I've found this post which describes the same behaviour:
http://mail.python.org/pipermail/python-dev/2002-January/019724.html

Comment 1 Thomas J. Baker 2007-12-09 23:34:56 UTC
I get similar problems with a standard gnome-terminal and standard xterm:

continuity> iotop
Traceback (most recent call last):
  File "/usr/bin/iotop", line 608, in <module>
    main()
  File "/usr/bin/iotop", line 604, in main
    curses.wrapper(run_iotop, options)
  File "/usr/lib64/python2.5/curses/wrapper.py", line 44, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/bin/iotop", line 562, in run_iotop
    ui = IOTopUI(win, process_list, options)
  File "/usr/bin/iotop", line 443, in __init__
    curses.use_default_colors()
_curses.error: use_default_colors() returned ERR
continuity> 


Comment 2 Adel Gadllah 2007-12-20 20:07:45 UTC
(In reply to comment #0)
> iotop works fine with normal xterm.
> I've found this post which describes the same behaviour:
> http://mail.python.org/pipermail/python-dev/2002-January/019724.html

looks like a termcap/terminfo bug. So added maintainer to CC.

Miroslav any ideas?

(In reply to comment #1)
> I get similar problems with a standard gnome-terminal and standard xterm:
> 
> continuity> iotop
> Traceback (most recent call last):
>   File "/usr/bin/iotop", line 608, in <module>
>     main()
>   File "/usr/bin/iotop", line 604, in main
>     curses.wrapper(run_iotop, options)
>   File "/usr/lib64/python2.5/curses/wrapper.py", line 44, in wrapper
>     return func(stdscr, *args, **kwds)
>   File "/usr/bin/iotop", line 562, in run_iotop
>     ui = IOTopUI(win, process_list, options)
>   File "/usr/bin/iotop", line 443, in __init__
>     curses.use_default_colors()
> _curses.error: use_default_colors() returned ERR
> continuity> 

This might be realted but I am unable to reproduce it.
Can you post detailed steps to reproduce it?



Comment 3 Miroslav Lichvar 2007-12-20 22:08:12 UTC
xterm-color entry is missing civis capability which is required for curs_set(0),
but I don't think that's a bug. The application should ignore the error.

Comment 4 Adel Gadllah 2007-12-28 14:43:44 UTC
(In reply to comment #3)
> xterm-color entry is missing civis capability which is required for curs_set(0),
> but I don't think that's a bug. The application should ignore the error.

OK , built a new build that does exactly this.

http://koji.fedoraproject.org/koji/buildinfo?buildID=29269

should hit updates-testing on the next push.

Please test and confirm/deny if it fixes the issue.

Comment 5 Fedora Update System 2008-01-03 01:47:45 UTC
iotop-0.1-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iotop'

Comment 6 Fedora Update System 2008-01-03 01:49:05 UTC
iotop-0.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iotop'

Comment 7 Ruben Kerkhof 2008-01-15 21:33:43 UTC
Thanks Adel, that fixes it.

Comment 8 Fedora Update System 2008-01-15 22:53:20 UTC
iotop-0.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-01-15 22:57:32 UTC
iotop-0.1-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.