Bug 400201 - pulse audio doesn't work
pulse audio doesn't work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 16:40 EST by markm
Modified: 2008-01-15 09:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of: grep pulse /var/log/messages* (10.77 KB, text/plain)
2007-12-27 07:42 EST, Dawid Lorenz
no flags Details

  None (edit)
Description markm 2007-11-26 16:40:28 EST
Description of problem:

I can play one stream at the time, when I try to run PulseAudio Volume Control,
it fails with an error: "Connection failed: Connection refused"

Version-Release number of selected component (if applicable):

lates update

How reproducible:

always

Additional info:

When I read in news that PulseAudio is going to be a default audio server in
Fedora 8, I knew it sounds like "Huston, we've got a problem" (with sound). At
the beginning it worked fine (with couple of small issue), now it doesn't work
at all and I can play only one audio stream at the time.

Don't get me wrong, I am happy to help, but how can I recommend fedora to
friends, while I know, that it won't work as desired?
Comment 1 Lennart Poettering 2007-11-29 18:59:38 EST
If you get this error, then PA has not been started.

I am not sure what might be the reason for this. Try starting pulseaudio
manually with "pulseaudio -vv" and checkif that works and paste the output here.
Comment 2 markm 2007-12-02 12:41:00 EST
[marek@Mareg ~]$ pulseaudio -v
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
I: module-hal-detect.c: Trying capability alsa
I: module-alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_27d8_alsa_playback_0" with
sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0
"alsa_output.pci_8086_27d8_alsa_playback_0.monitor" with sample spec "s16le 2ch
44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0").
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_27d8_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0").
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
E: module-protocol-stub.c: Failed to create socket directory
'/tmp/.esd-500/socket': Not a directory
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.
I: module.c: Unloading "module-alsa-sink" (index: #0).
I: sink.c: Freeing sink 0 "alsa_output.pci_8086_27d8_alsa_playback_0"
I: source.c: Freeing source 0 "alsa_output.pci_8086_27d8_alsa_playback_0.monitor"
I: module.c: Unloaded "module-alsa-sink" (index: #0).
I: module.c: Unloading "module-alsa-source" (index: #1).
I: source.c: Freeing source 1 "alsa_input.pci_8086_27d8_alsa_capture_0"
I: module.c: Unloaded "module-alsa-source" (index: #1).
I: module.c: Unloading "module-hal-detect" (index: #2).
I: module.c: Unloaded "module-hal-detect" (index: #2).
I: main.c: Daemon terminated.
[marek@Mareg ~]$ 
Comment 3 markm 2007-12-02 12:41:39 EST
[marek@Mareg ~]$ pulseaudio -vv > pulseaudio.txt
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0'
I: module-alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_27d8_alsa_playback_0" with
sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0
"alsa_output.pci_8086_27d8_alsa_playback_0.monitor" with sample spec "s16le 2ch
44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
D: module-alsa-sink.c: ALSA device has separate volumes controls for all 2 channels.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+30
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0'
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_27d8_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0").
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_hw_specific_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
E: module-protocol-stub.c: Failed to create socket directory
'/tmp/.esd-500/socket': Not a directory
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.
I: module.c: Unloading "module-alsa-sink" (index: #0).
D: module-alsa-sink.c: Thread shutting down
I: sink.c: Freeing sink 0 "alsa_output.pci_8086_27d8_alsa_playback_0"
I: source.c: Freeing source 0 "alsa_output.pci_8086_27d8_alsa_playback_0.monitor"
I: module.c: Unloaded "module-alsa-sink" (index: #0).
I: module.c: Unloading "module-alsa-source" (index: #1).
D: module-alsa-source.c: Thread shutting down
I: source.c: Freeing source 1 "alsa_input.pci_8086_27d8_alsa_capture_0"
I: module.c: Unloaded "module-alsa-source" (index: #1).
I: module.c: Unloading "module-hal-detect" (index: #2).
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus.Local,
path=/org/freedesktop/DBus/Local, member=Disconnected
I: module.c: Unloaded "module-hal-detect" (index: #2).
I: main.c: Daemon terminated.
[marek@Mareg ~]$ 
Comment 4 Dawid Lorenz 2007-12-03 05:51:13 EST
Same here. Sometimes, just randomly, without any obvious reason, PulseAudio
stops working properly. When I try to run PA Volume Control - 'Connection
refused' message. Trying to kill & restart PA is like lottery: when I run
pulseaudio -k in the command line, I might expect following:

1) nothing - literally nothing happens;
2) Gnome desktop gets treated with 'soft restart' (I don't know how to call it,
actually) - window decorations are gone, all font sizes are getting huge, I
cannot do stuff like move windows or switch workspaces etc. Basically I need to
restart X server;
3) X server is restarted without any warning - just bang! - and I'm back at
login screen; then, after X server restart:
3a) PA still doesn't work -> rebooting machine helps,
3b) PA works - wow!

As a final word: I like the idea of PulseAudio in general, but putting it into
final release, while it's still so buggy and unstable, wasn't the greatest idea
ever.

Btw, If I only get into 'connection refused' message again, I'll use suggestions
above to generate debug outpu, and put it here.
Comment 5 Dawid Lorenz 2007-12-06 07:11:43 EST
I've just ran into 'connection refused' issue, and output of pulseaudio -vv is
following:

[evad@dell640m run]$ pulseaudio -vv
E: pid.c: Daemon already running.
E: main.c: pa_pid_file_create() failed.
Comment 6 Dawid Lorenz 2007-12-06 07:20:35 EST
Update: removing /tmp/pulse-evad/pid file and then starting PA with pulseaudio
-D command helped. No restart of X server or machine necessary.
Comment 7 Jase Whipp 2007-12-11 14:45:59 EST
In reference to manually starting PA:

Pulseaudio and Alsa report errors when I attempt to test sound (System ->
Preferences -> Hardware -> Sound). What is the prescribed method for starting
PA? Is this supposed to be done by gconf? Why is the user being tasked with
starting PA manually?

The priority on this needs to be moved to high, I've tested on 4 different
systems, all fresh installs of Fedora 8, all sound besides OSS is broken. I was
able to restore ALSA functionality only after removing all pulse audio related
packages. Since Gnome is set to Auto detect by default, if PA and ALSA are
borked, the user will not notice until they try to have two applications playing
sound (e.g. Firefox isn't playing sound, mplayer reports sound errors, etc). 
Manually selecting pulseaudio or alsa in Gnome's sound config tool and
attempting to test visually reports a gstreamer error.

Obvious question: Why is this selected as the default for release? Esp. when
restoring sound functionality is so difficult. 
Comment 8 markm 2007-12-17 05:37:47 EST
[marek@Mareg ~]$ pulseaudio -v
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
I: module-hal-detect.c: Trying capability alsa
I: module-alsa-sink.c: Successfully enabled mmap() mode.
W: alsa-util.c: Cannot find mixer control "Master".
W: alsa-util.c: Cannot find fallback mixer control "PCM".
I: sink.c: Created sink 0 "alsa_output.pci_8086_284b_alsa_playback_0" with
sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0
"alsa_output.pci_8086_284b_alsa_playback_0.monitor" with sample spec "s16le 2ch
44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=hw:0
sink_name=alsa_output.pci_8086_284b_alsa_playback_0").
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_284b_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device=hw:0
source_name=alsa_input.pci_8086_284b_alsa_capture_0").
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
E: socket-server.c: bind(): Address already in use
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.
I: module.c: Unloading "module-alsa-sink" (index: #0).
I: sink.c: Freeing sink 0 "alsa_output.pci_8086_284b_alsa_playback_0"
I: source.c: Freeing source 0 "alsa_output.pci_8086_284b_alsa_playback_0.monitor"
I: module.c: Unloaded "module-alsa-sink" (index: #0).
I: module.c: Unloading "module-alsa-source" (index: #1).
I: source.c: Freeing source 1 "alsa_input.pci_8086_284b_alsa_capture_0"
I: module.c: Unloaded "module-alsa-source" (index: #1).
I: module.c: Unloading "module-hal-detect" (index: #2).
I: module.c: Unloaded "module-hal-detect" (index: #2).
I: main.c: Daemon terminated.
[marek@Mareg ~]$ 

when I am trying to start pulse audio manually.

is there anybody out there who's willing to help? guys, I really don't want to
spend half a day restarting my computer to get my sound working back. Can
someone post a quick solution how to make sound work? :(
Comment 9 Lubomir Kundrak 2007-12-20 06:34:07 EST
E: socket-server.c: bind(): Address already in use
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.

This might be a leftover ESD socket in /tmp. Aren't you running ESound? You had
an issue with it before:

E: module-protocol-stub.c: Failed to create socket directory
'/tmp/.esd-500/socket': Not a directory
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
"): initialization failed.

Please try: "ps aux |grep esd" and remove the esd sockets "/tmp/.esd*"

/me hails to insecure temporary files, we aren't going to get rid of them, are we?
Comment 10 Matt Britt 2007-12-27 05:32:21 EST
> What is the prescribed method for starting
PA? Is this supposed to be done by gconf? Why is the user being tasked with
starting PA manually?

After trying to get sound working for a couple of hours and finally realizing
that there isn't a script in any package anywhere (that I can find) to start PA,
I'd really like to know the answer to this question as well.  Surely the average
user isn't expected to know that they must start a terminal and summon daemons
to make sound come from their speakers rather than having arcane errors assault
them.  This is basic desktop functionality!

> Obvious question: Why is this selected as the default for release? Esp. when
restoring sound functionality is so difficult. 

Precisely my thoughts.  This is worse than when FC3 first included ALSA.  I
would just disable pulseaudio altogether and use my working ALSA configuration
if someone hadn't compiled the latest SDL packages to require it (thanks a lot).
 Instead, now I need to spend a few more hours learning about pulseaudio and
trying to acquaint myself well enough to fix all the quirks.  Are we going to be
stuck with this mess, or can you give us a way out so we can continue using ALSA
rather than being forced beta testers?

Sorry for the soapboxing, this is just my long-winded way of confirming the bug.
 I should note that my system was upgraded from a fresh install (I think) of FC7.
Comment 11 Lubomir Kundrak 2007-12-27 05:45:33 EST
(In reply to comment #10)
> > What is the prescribed method for starting
> PA? Is this supposed to be done by gconf? Why is the user being tasked with
> starting PA manually?

It is started with the GNOME session.
See System->Preferences->Personal->Sessions

> > Obvious question: Why is this selected as the default for release? Esp. when
> restoring sound functionality is so difficult. 

Because it worked well. Did you report problems before the release happened? It
really helps a lot when you can really help shooting bugs in the testing
releases rather than pointlessly complaining. Thanks for this report though.

> I would just disable pulseaudio altogether and use my working ALSA
> configuration if someone hadn't compiled the latest SDL packages to
> require it (thanks a lot).

Do you have a bug ID, preferrably with the explanation from the SDL maintainer?

>  Instead, now I need to spend a few more hours learning about pulseaudio and
> trying to acquaint myself well enough to fix all the quirks.  Are we going to be
> stuck with this mess, or can you give us a way out so we can continue using ALSA
> rather than being forced beta testers?

1.) You can completely remove pulseaudio (I guess you have the problems with
SDL, I'd prefer if it was configurable and depended opon users decision, so
please file a bug report)

2.) You can select ALSA as default output in GNOME and remove pulseaudio plugin
from ALSA (by removing alsa-plugins-pulseaudio package, or by removing or
commenting out /etc/alsa/pulse-default.conf)

> Sorry for the soapboxing, this is just my long-winded way of confirming the bug.
>  I should note that my system was upgraded from a fresh install (I think) of FC7.

If you had good intentions to help solving the problem, would you ming providing
some information that would help fixing it? Does exactly the same thing happen
to you? Do you have the same hardware?
Comment 12 Lubomir Kundrak 2007-12-27 05:47:54 EST
(In reply to comment #11)
> If you had good intentions to help solving the problem, would you ming providing
> some information that would help fixing it? Does exactly the same thing happen
> to you? Do you have the same hardware?

I've messed this up with another bug, so these questions are not pertinent.
Though, the former questions apply.
Comment 13 markm 2007-12-27 06:22:23 EST
(In reply to comment #11)
> (In reply to comment #10)
> > > What is the prescribed method for starting
> > PA? Is this supposed to be done by gconf? Why is the user being tasked with
> > starting PA manually?
> 
> It is started with the GNOME session.
> See System->Preferences->Personal->Sessions

brilliant! I went there, pulse audio is checked and should start when session
start, but it doesn't. Now I am listening to the radio (using rythmbox) and
tried to play audio file using totem - what I got was:

Totem could not play 'file:///home/marek/Music/Army of lovers -Crucified.mp3'.
This is an audio-only file, and there is no audio output available.

So Pulse Audio should start, but it doesn't start.

> > > Obvious question: Why is this selected as the default for release? Esp. when
> > restoring sound functionality is so difficult. 
> 
> Because it worked well. Did you report problems before the release happened? It
> really helps a lot when you can really help shooting bugs in the testing
> releases rather than pointlessly complaining. Thanks for this report though.

I am just average user of Fedora, who doesn't have time to install test releases
and when I run the release I expect it to work. If it doesn't work, I will post
a bug. and I did it. Looks like none cares about it. every few days I get
updates but nothing is being solved in that particular case. I am not a computer
genius and I don't know what kind of information you may need, so if you need
anything special, just ask and I am happy to help to solve this problem. But for
me it looks like Fedora developers are not keen on solving that particular one.

> If you had good intentions to help solving the problem, would you ming providing
> some information that would help fixing it? Does exactly the same thing happen
> to you? Do you have the same hardware?

I have a good intentions - I filled this bug report and I am happy to supply any
information you want, just tell me what do you exactly want.

Currently Pulse Audio doesn't work on my machine (Dell D620 Core 2 Duo 2GHz
T7200) and it doesn't work on my other machine (Dell Vostro 1500 Core 2 Duo
2.2GHz) and it doesn't work on my mate's machine too (Dell Inspirion 640m AFAIK
Core 2 Duo 2GHz). As you can see it's a common hardware.
Comment 14 markm 2007-12-27 06:28:21 EST
(In reply to comment #9)
> E: socket-server.c: bind(): Address already in use
> E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
> ""): initialization failed.
> E: main.c: Module load failed.
> E: main.c: failed to initialize daemon.
> 
> This might be a leftover ESD socket in /tmp. Aren't you running ESound?

I don't know what I am running, I want my sound to work. if Pulse Audio fails
probably my system tries to run whatever it finds - alsa / esd / oss - I don't
know. 

> You had an issue with it before:
> 
> E: module-protocol-stub.c: Failed to create socket directory
> '/tmp/.esd-500/socket': Not a directory
> E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
> "): initialization failed.

yeah and this "fix" wasn't a fix, it caused more problems, then helped actually.
I removed that "fix". 

> Please try: "ps aux |grep esd" and remove the esd sockets "/tmp/.esd*"

[marek@Mareg ~]$ ps aux |grep esd
marek     6950  0.0  0.0   4048   680 pts/0    S+   11:21   0:00 grep esd
[marek@Mareg ~]$ 


> /me hails to insecure temporary files, we aren't going to get rid of them, are
we? 

err, what?
Comment 15 Dawid Lorenz 2007-12-27 06:31:03 EST
Here's that mate with 'Dell Inspirion 640m AFAIK Core 2 Duo 2GHz' - I also use
Dell D620, and on both machines PA crashes intermittently, without any obvious
reason (usually deleting pid file and restarting PA resolves the problem).
However, I suspect it has something to do with Firefox and its Flash plugin, but
I've never actually did detailed investigation on that.
Comment 16 markm 2007-12-27 06:32:47 EST
also, when finally pulse audio works (started manually) it doesn't remember
volume values per stream - it would be really nice if pulse audio could remember
volume values per source. Currently it doesn't remember and every time I have to
set them manually. Thanks.
Comment 17 Lubomir Kundrak 2007-12-27 06:39:53 EST
(In reply to comment #13)
> (In reply to comment #11)
> > (In reply to comment #10)
> > > > What is the prescribed method for starting
> > > PA? Is this supposed to be done by gconf? Why is the user being tasked with
> > > starting PA manually?
> > 
> > It is started with the GNOME session.
> > See System->Preferences->Personal->Sessions
> 
> brilliant! I went there, pulse audio is checked and should start when session
> start, but it doesn't.

I thought you had a different problem, see comment #9.

So -- to sumarize:

E: socket-server.c: bind(): Address already in use
E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
""): initialization failed.

It seems like you are running ESound, which you shouldn't be (unless you need it
-- in that case please remove the esound module from /etc/pulse/default.pa, or
remove the pulseaudio-esound-compat package). If it is not esound who listens on
the esound socket, please check the following:

# netstat -lp |grep -E '1600|esd'

> Looks like none cares about it. every few days I get
> updates but nothing is being solved in that particular case. I am not a computer
> genius and I don't know what kind of information you may need, so if you need
> anything special, just ask and I am happy to help to solve this problem. But for
> me it looks like Fedora developers are not keen on solving that particular one.

Could you please stop pointlessly blaming people you expect help from? What do
you think I am doing now? The information you posted still didn't reveal a bug,
though I am trying to find out what was wrong to help you. It doesn't help a lot
blaming us of not caring.

> Currently Pulse Audio doesn't work on my machine (Dell D620 Core 2 Duo 2GHz
> T7200) and it doesn't work on my other machine (Dell Vostro 1500 Core 2 Duo
> 2.2GHz) and it doesn't work on my mate's machine too (Dell Inspirion 640m AFAIK
> Core 2 Duo 2GHz). As you can see it's a common hardware.

The same symptoms on all machines? Clean Fedora 8 installations or upgrades or
something heavily customized?
Comment 18 Lubomir Kundrak 2007-12-27 06:42:03 EST
Just had a middle-air conflict with you. Would you mind joining #fedora-devel on
freenode so we can more efficiently talk about the issue?

Dawid: Please file a bug report, and grep "pulse" through /var/log/messages if
there's something suspicious there. Thanks!
Comment 19 Dawid Lorenz 2007-12-27 06:52:35 EST
(In reply to comment #18)
> Dawid: Please file a bug report, and grep "pulse" through /var/log/messages if
> there's something suspicious there. Thanks!

OK, I'll try to do that next time I spot PA crash.
Comment 20 Lubomir Kundrak 2007-12-27 06:55:39 EST
Dawid: It could still be in logs. You can try to look now.
Comment 21 Dawid Lorenz 2007-12-27 07:16:03 EST
(In reply to comment #20)
> Dawid: It could still be in logs. You can try to look now.

OK, here it is:

[root@dell640m evad]# grep -5 pulse /var/log/messages
Dec 24 12:32:00 dell640m gnome-keyring-daemon[3065]:last message repeated 5 times
Dec 24 12:34:28 dell640m gnome-keyring-daemon[3065]:last message repeated 4 times
Dec 24 12:34:28 dell640m gnome-power-manager: (evad) Shutting down computer
because the power button has been pressed
Dec 24 12:34:28 dell640m shutdown[10506]: shutting down for system halt
Dec 24 12:34:29 dell640m gconfd (evad-3133): Received signal 15, shutting down
cleanly
Dec 24 12:34:29 dell640m pulseaudio[3141]: module-volume-restore.c: failed to
open file '(null)': No such file or directory
Dec 24 12:34:29 dell640m gconfd (evad-3133): Exiting
Dec 24 12:34:31 dell640m avahi-daemon[2754]: Got SIGTERM, quitting.
Dec 24 12:34:31 dell640m avahi-daemon[2754]: Leaving mDNS multicast group on
interface vmnet8.IPv4 with address 192.168.5.1.
Dec 24 12:34:31 dell640m avahi-daemon[2754]: Leaving mDNS multicast group on
interface eth1.IPv4 with address 192.168.10.9.
Dec 24 12:34:31 dell640m kernel: video bus notify
--
Dec 27 09:48:13 dell640m gdm-binary[2965]: GLib-WARNING: In call to
g_spawn_sync(), exit status of a child process was requested but SIGCHLD action
was set to SIG_IGN and ECHILD was received by waitpid(), so exit status can't be
returned. This is a bug in the program calling g_spawn_sync(); either don't
request the exit status, or don't set the SIGCHLD action.
Dec 27 09:48:14 dell640m gconfd (evad-3139): starting (version 2.20.1), pid 3139
user 'evad'
Dec 27 09:48:14 dell640m gconfd (evad-3139): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration
source at position 0
Dec 27 09:48:14 dell640m gconfd (evad-3139): Resolved address
"xml:readwrite:/home/evad/.gconf" to a writable configuration source at position 1
Dec 27 09:48:14 dell640m gconfd (evad-3139): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source
at position 2
Dec 27 09:48:18 dell640m pulseaudio[3147]: pid.c: Stale PID file, overwriting.
Dec 27 09:48:22 dell640m gconfd (evad-3139): Resolved address
"xml:readwrite:/home/evad/.gconf" to a writable configuration source at position 0
Dec 27 09:48:22 dell640m hcid[2515]: Default passkey agent (:1.13,
/org/bluez/passkey) registered
Dec 27 09:48:22 dell640m hcid[2515]: Default authorization agent (:1.13,
/org/bluez/auth) registered
Dec 27 09:48:29 dell640m gdl_service: E 12-27 09:48:27  3201      gdl_service
sconstest.cc:38] not in a valid building path. can not find the root dir.
Dec 27 09:48:31 dell640m gdl_config: E 12-27 09:48:30  3218       gdl_config
sconstest.cc:38] not in a valid building path. can not find the root dir.
Comment 22 Lubomir Kundrak 2007-12-27 07:37:02 EST
Dawid: Thanks. There's no problem in the log. Please try grepping
/var/log/messages*, so that you also look in the rotated logs. Also, the 5 lines
of context are not interesting.
Comment 23 Dawid Lorenz 2007-12-27 07:42:00 EST
Created attachment 290451 [details]
output of: grep pulse /var/log/messages*
Comment 24 Dawid Lorenz 2007-12-27 07:42:45 EST
(In reply to comment #23)
> Created an attachment (id=290451) [edit]
> output of: grep pulse /var/log/messages*
> 

OK, output file attached as separate file.
Comment 25 Lubomir Kundrak 2007-12-27 07:52:12 EST
Dawid: From the log, no problems with pulseaudio on your machine are obvious.
Please kill it if it runs now ("pulseaudio -k"), run it in terminal (preferrably
verbosely, with "pulseaudio -vvv") and observe how and when does it die. Does it
crash immediatelly after you launch it? Or, as you said, could you try some
firefox/flash with sounds? Does it receive a fatal signal? If so, please try to
get core dump ("ulimit -c unlimited" before running it in terminal) and please
attempt to get a backtrace (you'll need pulseaudio-debuginfo for a reasonable one).
Comment 26 Dawid Lorenz 2007-12-27 07:54:34 EST
(In reply to comment #25)
> Dawid: From the log, no problems with pulseaudio on your machine are obvious.
> Please kill it if it runs now ("pulseaudio -k"), run it in terminal (preferrably
> verbosely, with "pulseaudio -vvv") and observe how and when does it die. Does it
> crash immediatelly after you launch it? Or, as you said, could you try some
> firefox/flash with sounds? Does it receive a fatal signal? If so, please try to
> get core dump ("ulimit -c unlimited" before running it in terminal) and please
> attempt to get a backtrace (you'll need pulseaudio-debuginfo for a reasonable
one).

Thanks for suggestions, I'll try to do them in spare time and post back results
(if any).
Comment 27 markm 2007-12-30 08:45:50 EST
[marek@Mareg ~]$ W: pid.c: Stale PID file, overwriting.
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
I: module-hal-detect.c: Trying capability alsa
E: module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0"): initialization failed.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 0 "alsa_input.pci_8086_27d8_alsa_capture_0" with
sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: module.c: Loaded "module-alsa-source" (index: #0; argument: "device=hw:0
source_name=alsa_input.pci_8086_27d8_alsa_capture_0").
I: module-hal-detect.c: Loaded 1 modules.
I: module.c: Loaded "module-hal-detect" (index: #1; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #2; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #3; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #4; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #5; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #6; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #7; argument: "").
I: module.c: Loaded "module-x11-publish" (index: #8; argument: "").
I: module.c: Loaded "module-gconf" (index: #9; argument: "").
I: main.c: Daemon startup complete.
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_27d8_alsa_capture_0 idle
for too long, suspending ...
I: module-alsa-source.c: Device suspended...

[marek@Mareg ~]$ 

just after starting my session, music is not playing, no sounds, and pulseaudio
were down, after trying to start it, I get red errors, that alsa startup failed.
Comment 28 markm 2007-12-30 08:55:09 EST
(In reply to comment #17)
> (In reply to comment #13)
> > (In reply to comment #11)
> > > (In reply to comment #10)
> I thought you had a different problem, see comment #9.
> 
> So -- to sumarize:
> 
> E: socket-server.c: bind(): Address already in use
> E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
> ""): initialization failed.
> 
> It seems like you are running ESound, which you shouldn't be (unless you need it
> -- in that case please remove the esound module from /etc/pulse/default.pa, or
> remove the pulseaudio-esound-compat package). If it is not esound who listens on
> the esound socket, please check the following:
> 
> # netstat -lp |grep -E '1600|esd'

[marek@Mareg ~]$ netstat -lp |grep -E '1600|esd'
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
unix  2      [ ACC ]     STREAM     LISTENING     388578 -                  
/tmp/.esd-500/socket
[marek@Mareg ~]$ 
 
> > Looks like none cares about it. every few days I get
> > updates but nothing is being solved in that particular case. I am not a computer
> > genius and I don't know what kind of information you may need, so if you need
> > anything special, just ask and I am happy to help to solve this problem. But for
> > me it looks like Fedora developers are not keen on solving that particular one.
> 
> Could you please stop pointlessly blaming people you expect help from? What do
> you think I am doing now? The information you posted still didn't reveal a bug,
> though I am trying to find out what was wrong to help you. It doesn't help a lot
> blaming us of not caring.

sorry for pointlessly blaming people.

> > Currently Pulse Audio doesn't work on my machine (Dell D620 Core 2 Duo 2GHz
> > T7200) and it doesn't work on my other machine (Dell Vostro 1500 Core 2 Duo
> > 2.2GHz) and it doesn't work on my mate's machine too (Dell Inspirion 640m AFAIK
> > Core 2 Duo 2GHz). As you can see it's a common hardware.
> 
> The same symptoms on all machines? Clean Fedora 8 installations or upgrades or
> something heavily customized?

Clean Fedora 8 installation with latest upgrades and some extra rpms from
freshrpms.net. I prefer to use only rpms and offical fedora repos, I don't use
livna though.
Comment 29 Lubomir Kundrak 2007-12-30 09:01:27 EST
Marek: Isn't the error messgae here obvious?

I: module-hal-detect.c: Trying capability alsa
E: module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_27d8_alsa_playback_0"): initialization failed.

Something else is accessing your sound device and won't let pulseaudio use it.
To see what it is, do:

fuser -v /dev/snd/*
Comment 30 Lubomir Kundrak 2007-12-30 09:03:40 EST
(In reply to comment #28)
> > So -- to sumarize:
> > 
> > E: socket-server.c: bind(): Address already in use
> > E: module.c: Failed to load  module "module-esound-protocol-unix" (argument:
> > ""): initialization failed.
> > 
> > It seems like you are running ESound, which you shouldn't be (unless you need it
> > -- in that case please remove the esound module from /etc/pulse/default.pa, or
> > remove the pulseaudio-esound-compat package). If it is not esound who listens on
> > the esound socket, please check the following:
> > 
> > # netstat -lp |grep -E '1600|esd'
> 
> [marek@Mareg ~]$ netstat -lp |grep -E '1600|esd'
> (Not all processes could be identified, non-owned process info
>  will not be shown, you would have to be root to see it all.)
> unix  2      [ ACC ]     STREAM     LISTENING     388578 -                  
> /tmp/.esd-500/socket
> [marek@Mareg ~]$ 

A-ha! Something is listening on the esd socket. Please look what is the process
388578, either with "ps", or by running the same command as above with root
privileges.

> > The same symptoms on all machines? Clean Fedora 8 installations or upgrades or
> > something heavily customized?
> 
> Clean Fedora 8 installation with latest upgrades and some extra rpms from
> freshrpms.net. I prefer to use only rpms and offical fedora repos, I don't use
> livna though.

Thanks
Comment 31 markm 2008-01-15 09:26:02 EST
I did a fresh Fedora 8 installation with latest updates and Pulse Audio now
works fine. I got a fresh user settings too...

anyway, what I have discovered, when I was closing down my computer, pulse audio
were crashing that is why after restart pulse audio could not start and forced
me to manually pid removal, then it worked fine.

Anyway now (after os reinstall) it works fine. Thanks for your patience :)

Note You need to log in before you can comment on or make changes to this bug.