Bug 400381 - HTS add the USB test suites to test plan on the machine without USB components
HTS add the USB test suites to test plan on the machine without USB components
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
:
: 439328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 19:24 EST by Shengliang Lv
Modified: 2010-10-22 16:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: hts-5.2-16.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 13:19:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The sysreport of this system. (1.56 MB, application/octet-stream)
2007-11-26 19:24 EST, Shengliang Lv
no flags Details

  None (edit)
Description Shengliang Lv 2007-11-26 19:24:37 EST
Description of problem:
On HP Superdome-sx1000 system, after I installed all the HTS packages, I 
run "hts plan", it will add the USB test suites to the test plan even there 
isn't USB components on this machine, hts version is hts-5.1-13

[root@whale2 proc]# hts print
loaded configuration /var/hts/config.xml
loaded plan /var/hts/plan.xml

Test Plan:
----------------------------------------------------------------
usb
network    eth10      net_00_12_79_42_fd_76
network    eth14      net_00_0c_fc_00_25_e9
network    eth13      net_00_17_a4_51_ae_25
network    eth12      net_00_17_a4_51_ae_24
network    eth15      net_00_30_6e_2b_3f_87
network    eth9       net_00_12_79_42_fd_75
network    eth8       net_00_12_79_42_fd_74
network    eth7       net_00_12_79_43_ab_03
network    eth6       net_00_12_79_43_ab_02
network    eth5       net_00_12_79_43_ab_01
network    eth4       net_00_12_79_43_ab_00
network    eth11      net_00_12_79_42_fd_77
network    eth1       net_00_30_6e_e9_7e_3d
network    eth0       net_00_30_6e_e9_ae_ca
memory
storage    sda        storage_serial_20011c6fffe632bbf
storage    sdb        storage_serial_20011c6fffe565d9b
storage    sdc        storage_serial_2000c50fffe96a4ec
storage    sdd        storage_serial_20011c6fffe631ec0
storage    sde        storage_serial_2000c50fffe969201
storage    sdf        storage_serial_2000c50fffe96a1ec
storage    sdg        storage_serial_2000c50fffe966a54
storage    sdh        storage_serial_20011c6fffe5afc9c
storage    sdi        storage_serial_20011c6fffe56931a
storage    sdj        storage_serial_20011c6fffe569758
storage    sdk        storage_serial_20010b9ff0a1d8a0d
storage    sdl        storage_serial_20010b9fe51100500
storage    cciss/c0d0 pci_e11_46_0
storage    cciss/c1d0 pci_e11_46
core
info

[root@whale2 hts]# cat config.xml
<?xml version='1.0' encoding='UTF-8'?>
<certification-test discover-time='2007-11-23 05:27:13' hts-release='13' hts-
version='5.1'>
  <hardware>
    <arch>ia64</arch>
    <vendor>Hewlett-Pachard</vendor>
    <model>Superdome-sx1000</model>
    <make>Integrity</make>
  </hardware>
  <certification>
    <os>
      <name>Tikanga</name>
      <release>5.1</release>
    </os>
  </certification>
</certification-test>

Version-Release number of selected component (if applicable):
[root@whale2 proc]# uname -a
Linux whale2.orca.test 2.6.18-53.el5xen #1 SMP Wed Oct 10 16:51:32 EDT 2007 
ia64 ia64 ia64 GNU/Linux

How reproducible:


Steps to Reproduce:
1. Install hts-5.1-13 on the machine without USB components.
2. run "hts plan" to create the test plan
3.
  
Actual results:
Add the USB test suite to hts test plan.

Expected results:
Without usb test suite in the machine without usb components.

Additional info:
Comment 1 Shengliang Lv 2007-11-26 19:24:37 EST
Created attachment 269431 [details]
The sysreport of this system.
Comment 2 Greg Nichols 2007-11-26 21:59:12 EST
when the usb test is run, can you enter 0 for the number of ports?
Comment 3 Shengliang Lv 2007-11-27 00:46:45 EST
I can, but if I enter 0 the test enter loop-ask me again for the usb number, I 
can't continue the test.
Comment 4 Greg Nichols 2007-11-27 09:46:30 EST
As a work-around, you should be able to disable the usb test via the following
command:

hts plan --disable --test usb

Comment 5 Shengliang Lv 2007-12-12 12:58:48 EST
This bug is still not fixed in hts-5.1-16.
Comment 6 Greg Nichols 2008-02-27 10:08:54 EST
Fixed in HTS 5.1 R19 (and also HTS 5.2)
Comment 7 Greg Nichols 2008-04-14 15:37:53 EDT
*** Bug 439328 has been marked as a duplicate of this bug. ***
Comment 10 Hao Liu 2008-06-19 00:56:28 EDT
Hi, Shengliang
  I'm verifying the bug has been fixed, would you please provide an environment
as you described for testing ? Thank you.
Comment 11 Shengliang Lv 2008-06-19 01:48:43 EDT
Hao Liu,
  I will test it soon and tell you the results.

Bill
Comment 12 Hao Liu 2008-06-19 06:26:38 EDT
Shengliang,
  Wow!! That'll be really appreciated, thank you very much.
Comment 13 Lawrence Lim 2008-06-20 13:19:23 EDT
Resolving due to lack of hardware for verification. Please reopen the bug if the
problem persist.
Comment 14 Shengliang Lv 2008-06-23 23:15:40 EDT
I vefify this issue on RHEL5.2, I used hts-5.2-13.

Bill

Note You need to log in before you can comment on or make changes to this bug.