Bug 400391 - Unable to detect Fedora 8 install tree during installation
Unable to detect Fedora 8 install tree during installation
Status: CLOSED DUPLICATE of bug 384791
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-26 19:30 EST by Adam Stokes
Modified: 2009-12-14 16:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 10:52:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add support for Fedora 8 install tree (713 bytes, patch)
2007-11-26 19:30 EST, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2007-11-26 19:30:32 EST
Description of problem:
RHEL5.1 Virtualisation host, when installing a Fedora 8 para-virt guest fails
with a traceback, even though the install tree URL is correct.

Version-Release number of selected component (if applicable):
python-virtinst-0.103.0

How reproducible:
100%

Steps to Reproduce:
Install RHEL5 update 1 , add Virtualisation Platform and boot to the dom0
kernel.Using the Virtualisation Manager GUII tool, begin a new guest
installation. Select 'Parra Virtualised, and entre a valid installation tree
URL, ie :

http://mirror.pacific.net.au/linux/fedora/linux/releases/8/Fedora/ x86_64/os/
  
Actual results:
A trace back error appears:

Unable to complete install: 'Could not find an installable distribution the
install location'

Unable to complete install 'exceptions.RuntimeError Could not find an
installable distribution the install location
Traceback (most recent call last):
 File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
   dom = guest.start_install(False, meter = meter)
 File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 647, in
start_install
   tmpfiles = self._prepare_install_location(meter)
 File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 65, in
_prepare_install_location
   (kernelfn,initrdfn,args) = DistroManager.acquireKernel(self.location, meter,
scratchdir=self.scratchdir, type=self.type)
 File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 573, in
acquireKernel
   progresscb=progresscb, distro=distro, scratchdir=scratchdir)
 File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 562, in
_storeForDistro
   raise RuntimeError, "Could not find an installable distribution the install
location"
RuntimeError: Could not find an installable distribution the install location

Expected results:
Fedora 8 parra-virtualised installation should be possible.

Additional info:
Simple change to the /usr/lib/python2.4/site-packages/virtinst/DistroManager.py
file that is already in Fedora 8's python-virtinst RPM fixes the problem. At
line about 205 add code to look for the fedora.css file:

...,
# Fedora distro check
class FedoraImageStore(RedHatImageStore):
   def isValidStore(self, fetcher, progresscb):
       if fetcher.hasFile("fedora.css", progresscb):
           logging.debug("Detected a Fedora distro")
           return True
       if fetcher.hasFile("Fedora", progresscb):
           logging.debug("Detected a Fedora distro")
           return True
       return False
Comment 1 Adam Stokes 2007-11-26 19:30:32 EST
Created attachment 269441 [details]
Add support for Fedora 8 install tree
Comment 2 Daniel Berrange 2007-11-28 10:52:04 EST

*** This bug has been marked as a duplicate of 384791 ***

Note You need to log in before you can comment on or make changes to this bug.