This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 400651 - GFS: wrong locking order in gfs_get_parent()
GFS: wrong locking order in gfs_get_parent()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kiersten (Kerri) Anderson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 04:53 EST by Vasily Averin
Modified: 2010-01-11 22:27 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0348
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix wrong locking order in gfs_get_parent() (458 bytes, patch)
2007-11-27 04:53 EST, Vasily Averin
no flags Details | Diff

  None (edit)
Description Vasily Averin 2007-11-27 04:53:21 EST
Dmitry Monakhov from OpenVZ linux kernel team reports about wrong locking order
in gfs_get_parent(). Almost all coresponding places was fixed in
gfs-kmod-0.1.19-7.el5, but gfs_get_parrent() was missed.

The problem is fixed by attached patch.
Comment 1 Vasily Averin 2007-11-27 04:53:21 EST
Created attachment 269561 [details]
Fix wrong locking order in gfs_get_parent()
Comment 2 Wendy Cheng 2007-11-27 10:06:53 EST
This is probably an oversight of mine while doing last round of NFS fixes.
Will check into this. 
Comment 3 Wendy Cheng 2008-01-02 10:08:32 EST
Patch checked into CVS today - should be ready for RHEL 5.2.
Comment 4 Wendy Cheng 2008-01-02 10:10:17 EST
CVSROOT:	/cvs/cluster
Module name:	cluster
Branch: 	RHEL5
Changes by:	wcheng@sourceware.org	2008-01-02 15:07:07

Modified files:
	gfs-kernel/src/gfs: ops_export.c 

Log message:
        Dmitry Monakhov from OpenVZ linux kernel team reports about wrong
        locking order in gfs_get_parent(). Patch submitted by Vasily Averin
        (vvs@sw.ru) under Red Hat bugzilla 400651

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/cluster/gfs-kernel/src/gfs/ops_export.c.diff?cvsroot=cluster&only_with_tag=RHEL5&r1=1.8.2.3&r2=1.8.2.4
Comment 10 errata-xmlrpc 2008-05-21 11:37:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0348.html

Note You need to log in before you can comment on or make changes to this bug.