Bug 400701 - exclude= in yum.conf sledgehammers 'yum list'
exclude= in yum.conf sledgehammers 'yum list'
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 05:55 EST by Valdis Kletnieks
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 08:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2007-11-27 05:55:31 EST
Description of problem:
Recent xorg changes break with the NVidia binary driver, so I did the reasonable
Rawhide work-around and stuck 'xorg-x11-server-xorg' (and 3 or 4 dependent RPMs)
into the exclude= list so I'd not get them auto-updated and break my config.

So today, I wonder idly what release the xorg RPMs are up to, so I do:

# yum list 'xorg-x11-server*'
Loading "refresh-updatesd" plugin
Excluding Packages in global exclude list
Finished
Installed Packages
xorg-x11-server-Xorg.x86_64              1.3.0.0-33.fc8         installed       
xorg-x11-server-common.x86_64            1.4.99.1-0.10.fc9      installed       
xorg-x11-server-devel.x86_64             1.4.99.1-0.10.fc9      installed       
xorg-x11-server-utils.x86_64             7.3-1.fc8              installed       
Available Packages
xorg-x11-server-Xdmx.x86_64              1.4.99.1-0.10.fc9      development     
xorg-x11-server-Xephyr.x86_64            1.4.99.1-0.10.fc9      development     
xorg-x11-server-Xnest.x86_64             1.4.99.1-0.10.fc9      development     
xorg-x11-server-Xvfb.x86_64              1.4.99.1-0.10.fc9      development     
xorg-x11-server-devel.i386               1.4.99.1-0.10.fc9      development     
xorg-x11-server-source.x86_64            1.4.99.1-0.10.fc9      development

Wow. I'm *totally* not seeing xorg-x11-server-xorg 1.4.99.1-0.10.fc9, because
the exclude= has made even 'yum list' exclude it.  This would really suck if I
had been told "wait till 1.4.99.5 comes out', because I'd never *see* it and
know it was time to remove the exclude= entry.

And it's not just xorg, either - I have gdm in exclude= for another issue, and
yum says this:

# yum list gdm
Loading "refresh-updatesd" plugin
Excluding Packages in global exclude list
Finished
Installed Packages
gdm.x86_64                               1:2.20.1-5.fc8         installed       

Nope, no mention of the 2.21.2-0.2007.11.20.2.fc9 that's available.  Same thing
for several other RPMs I do an exclude= because the Rawhide version breaks
something...


Version-Release number of selected component (if applicable):
yum-3.2.7-1.fc8


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Anything referenced in a exclude= evaporates and can't be listed.


Expected results:
I was *expecting* that it would at least *list* the RPM, and possibly a
'(blocked)' or similar flag.


Additional info:
Comment 1 Valdis Kletnieks 2007-11-27 05:58:31 EST
I'd be perfectly willing to accept the current behavior as the *default*, if
there was some way to do a 'yum list --all-i-mean-it [list of RPMs] to override it.
Comment 2 James Antill 2007-11-27 08:28:56 EST
 In the next upstream release there is a --disableexcludes option.
Comment 3 Valdis Kletnieks 2007-11-27 09:30:29 EST
OK, that works for me.. ;)

Note You need to log in before you can comment on or make changes to this bug.