Bug 400711 - missing requirements
missing requirements
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iotop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 05:58 EST by Karsten Hopp
Modified: 2008-01-06 10:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 10:28:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-11-27 05:58:06 EST
Description of problem:
iotop needs python >= 2.5 and kernel 2.6.20 or newer:
> iotop
Could not run iotop as some of the requirements are not met:
- Python >= 2.5 for AF_NETLINK support: Not found
- Linux >= 2.6.20 with I/O accounting support: Not found
These requirements should be added to the rpm requirements so that you can't
install iotop when you don't met the requirements.

Version-Release number of selected component (if applicable):
iotop-0.1-1.fc9
Comment 1 Adel Gadllah 2007-11-28 08:28:09 EST
on which system are you running it?
Its only shipped in f7,f8 and rawhide where python < 2.5 and kernel < 2.6.20
where never shipped.
Comment 2 Karsten Hopp 2007-11-29 05:36:30 EST
RHEL-5. The package installled without a problem, but obviously didn't run when
it checked its requirements
Comment 3 Adel Gadllah 2007-12-01 04:40:28 EST
And thats the reason why its not in epel4/5 .
I can add the requiments but I don't think it makes sense to add them for
distros where its not shipped at all.
Comment 4 Adel Gadllah 2008-01-06 10:28:47 EST
OK, closing as NOTABUG for now.

Note You need to log in before you can comment on or make changes to this bug.