Bug 40072 - up2date cannot load the font -*-helvetica-bold-r-normal--12-*-*-*-p-*-iso8859-1 and exits
up2date cannot load the font -*-helvetica-bold-r-normal--12-*-*-*-p-*-iso8859...
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-05-10 09:35 EDT by John Killian O'Brien
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-05 16:08:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Killian O'Brien 2001-05-10 09:35:55 EDT
Description of Problem: When calling up2date, a traceback appears with a 
RuntimeError: couldn't load the font. up2date exits without connecting to 

How Reproducible: Always

Steps to Reproduce:
1. log in as root
2. call up2date from an xterm

Actual Results: A window flashes open briefly and then closes. The 
following message appears in the xterm.

Traceback (innermost last):
  File "/usr/sbin/up2date", line 831, in ?
  File "/usr/sbin/up2date", line 817, in main
  File "/usr/share/rhn/up2date/gui.py", line 701, in main
    gui = Gui()
  File "/usr/share/rhn/up2date/gui.py", line 69, in __init__
    style.font = 
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2610, in load_font
    return _gtk.gdk_font_load(font)
RuntimeError: couldn't load the font

Expected Results: up2date should connect to redhat and check for upgrades.

Additional Information: This problem appeared after an upgrade from RH7.0 
-> 7.1

rpm -q up2date kdebase kdelibs kernel python pygtk XFree86
Comment 1 Adrian Likins 2001-05-29 16:00:22 EDT
Gotten some reports that this bug goes away after a restart of
xfs and X. Can you verify that is the case?

Will attempt to change the up2date code to handle not being
able to find this font, but the root of the issue seems to
be some sort of Xfree/xfs bug...
Comment 2 John Killian O'Brien 2001-05-30 07:05:15 EDT
Not for me, I'm afraid. I get exactly the same error (did I do it
right? I killed the xfs pid and then restarted xfs with the same
options, tried up2date, hit ctrl-alt-backspace, logged back in,
tried up2date again).

I think you're right though about it being down to an X bug, I'm 
having severe problems with kde (I did all the above in gnome)
and the folks at bugs.kde.org think it has to do with xft.


Comment 3 John Killian O'Brien 2001-06-13 12:46:29 EDT
Upgrading to XFree86-4.1.0 seems to resolve this problem.
Recommend closing.

Note You need to log in before you can comment on or make changes to this bug.