Bug 40084 - rpm --relocate fails in RPMDELETE
rpm --relocate fails in RPMDELETE
Status: CLOSED DUPLICATE of bug 39943
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-05-10 10:42 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-10 10:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-10 10:42:24 EDT
Description of Problem:
rpm -i --relocate fails 

How Reproducible:
install a package and use the --relocate option

Steps to Reproduce:
1. rpm -i --relocate /opt/informix=/home/informix IDS.rpm

Actual Results:
error: can't unlink /homeinformix-RPMDELETE: Is a directory
error: can't rename /homeinformix to /homeinformix-RPMDELETE: Is a

Expected Results:
Install IDS in the /home/informix directory

Additional Information:
Comment 1 Jeff Johnson 2001-05-10 10:56:44 EDT

*** This bug has been marked as a duplicate of 39943 ***
Comment 2 Need Real Name 2001-06-13 09:00:19 EDT
I can't find any updates on this. Is there any Red Hat Linux General Bugfix
Advisory about this?
I have the same problem with RPM version 4.0.2 on a Red Hat Linux 7.0
Comment 3 Jeff Johnson 2001-06-13 09:21:02 EDT
Try rpm-4.0.3, either from Raw Hide, or, for just the relocate fixes
in rpm-4.0.3-0.6:
Comment 4 Need Real Name 2001-06-13 16:27:11 EDT
It worked! I downloaded the packages correponding to 4.0.3 version from the URL
you gave me. Thank you for the quick help.
One last question, this bugzilla is for developers at Red Hat or is for the
whole company. I mean when the status here says "RESOLVED" means that it's
resolved in the development stage or in the production stage?
Because we had this problem (the one with the relocate)with other product from
Informix, and their support told us tu get the patch that solves this Bug ID,
but I visited the Errata page corresponding to Red Hat 7.1 and couldn't find the
package for the update, since I use to install only official Red Hat package for
production servers, I'm worry about this particular case.
I'm in a testing stage right now, but I would rather install official updates in
our productions servers, than this from ftp.rpm.org that you pointed me.

Comment 5 Jeff Johnson 2001-06-13 16:41:23 EDT
Bugziilla is a software bug tracking system, not a full blown errata
tracking system, so RESOLVED is pretty much from a development point
of view.

Meanwhile, there won't be an errata for the broken rpm --relocate because
	1) the impact is small (e.g. most users don't give a whit about --relocate)
	2) there are alternatives, such as Raw Hide and ftp.rpm.org
so ftp.rpm.org is about as official as it's gonna get for now ...

Note You need to log in before you can comment on or make changes to this bug.