Bug 401241 - /usr/lib/news/lib/innshellvars not properly sourced
/usr/lib/news/lib/innshellvars not properly sourced
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 11:12 EST by Need Real Name
Modified: 2008-01-18 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.4.3-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 18:09:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected init script (3.10 KB, text/plain)
2007-12-10 09:32 EST, Ondrej Dvoracek
no flags Details
corrected innd.init file (3.11 KB, patch)
2008-01-07 10:32 EST, Ondrej Vasik
no flags Details | Diff

  None (edit)
Description Need Real Name 2007-11-27 11:12:23 EST
Description of problem:

In previous versions (e.g., FC6), the sourcing of /usr/lib/news/lib/innshellvars
used to occur at the top of the /etc/init.d/innd file outside of the switch.
Now the sourcing only occurs inside the "start" portion of the switch.

However, innshellvars includes the definition of the variable NEWSBIN which is
explicitly referenced in the "stop" portion.

This causes soft stops of innd to fail
Comment 1 Need Real Name 2007-12-09 15:08:47 EST
Anybody working on this.
The fix is simple and critical because otherwise stopping innd leads to a hard
stop which can leave innd in a bad state potentially requiring rebuild of
history files.

THIS SHOULD BE FIXED ASAP.
Comment 2 Ondrej Dvoracek 2007-12-10 09:32:20 EST
Created attachment 282821 [details]
Corrected init script

Hi,
please try this init script and let me know if it does what you want.
Thanks,
Ondrej.
Comment 3 Need Real Name 2007-12-10 11:41:40 EST
I'm sure that will fix my problem.
But why do you also want to move the statement:
  [ -f "$HISTORY" -a -f "$HISTORY.hash" ] || ...
to go before the start() subroutine.
This would mean that you couldn't stop innd if you need to rebuild the history
file -- while the first step in safely rebuilding the history/overview database
is to stop innd!

Similar comments may or may not apply to moving [ -d "$SPOOLBASE" ] but I
haven't thought through the pros/cons.

In general, I would lean towards the side of being lax in letting people stop
services while being strict before allowing services to start up.
  
Comment 4 Need Real Name 2007-12-18 11:21:39 EST
Any idea when these changes might make it into updates?
Comment 5 Eric de Hont 2007-12-19 15:12:23 EST
Ondrej,

I've tested the corrected init script on my system and it works fine.

]# uname -a
Linux news119 2.6.21-2952.fc8xen #1 SMP Mon Nov 19 07:06:55 EST 2007 i686 i686
i386 GNU/Linux

-- 
Eric
Comment 6 Need Real Name 2008-01-01 02:24:22 EST
Any idea when these changes might make it into updates?

The bug being corrected is simple yet serious -- why not release the updated
package?

Also, per comment #3, I think some fine tuning could be made to the fix
Comment 7 Ondrej Vasik 2008-01-07 10:32:14 EST
Created attachment 290963 [details]
corrected innd.init file

Sorry for delay. Since today I'm new maintainer of inn, so this is answer for
delay - package was orphaned by previous maintainer.
I read your comments - 
ad #3) I think that's because it was done that way in F-7 and FC-6 - before
initscript review (#246951) - but I think you are right and those two could be
moved back inside start(). I added init file that I'm going to commit to devel
and F-8 testing branch, let me know about your objections. Thanks.
Comment 8 Need Real Name 2008-01-07 22:11:43 EST
Thanks - looks good to me!
Comment 9 Fedora Update System 2008-01-11 17:18:43 EST
inn-2.4.3-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update inn'
Comment 10 Eric de Hont 2008-01-12 18:48:05 EST
The update looks/works fine, but it's only half of the problem with innd.

We also need an update of rsyslog.conf. (syslog.conf in fedora 7)

The changes should include:
*.info;mail.none;authpriv.none;cron.none;news.none      /var/log/messages

#
# INN
#
news.=crit                                        /var/log/news/news.crit
news.=err                                         /var/log/news/news.err
news.notice                                       /var/log/news/news.notice
news.=debug                                       /var/log/news/news.debug

Comment 11 Ondrej Vasik 2008-01-13 11:40:36 EST
(In reply to comment #10)
Thanks for info/report, will fix that soon - rsyslog.conf replaced sysklogd in
Fedora 8, so the spec file has to be fixed. But it has nothing to do with that
bugzilla, so this one will get closed once the update inn-2.4.3-8.fc8 will be
pushed to stable. You could open new bugzilla ticket if you want to track this
issue or you could wait for next release of inn in F8 testing/rawhide(hopefully
in few days).
Comment 12 Fedora Update System 2008-01-15 18:09:48 EST
inn-2.4.3-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Ondrej Vasik 2008-01-16 08:45:07 EST
(In reply to comment #10)
Eric de Hont (edehont@xs4all.nl) >
I just commited and built version for F8 and RAWHIDE ( inn-2.4.3-9.fc8 (fc9) ,
which should use rsyslog conf and pid files instead of sysklogd - could you
please check the changes? 
I will push the update to testing...
Thanks in advance...

Comment 14 Eric de Hont 2008-01-16 17:55:33 EST
(In reply to comment #13)
I'm rather new to Bugzilla and this testing... Could you please instruct me
which commands to use to install your update? (Like in comment #9)

I have a spare fc8 virtual machine standing by for testing purposes and am
willing to create a new vm if needed.

Entering a new bugzilla entry doesn't seem a bad idea, does it?

Shall I title it 'news-entries missing in rsyslog.conf'?
Comment 15 Ondrej Vasik 2008-01-17 04:27:12 EST
(In reply to comment #14)
> I'm rather new to Bugzilla and this testing... Could you please instruct me
> which commands to use to install your update? (Like in comment #9)

  Same command as written in comment #9 will work for testing this issue.
  Date: 	Wed, 16 Jan 2008 08:20:07 -0700  (16:20 CET)
  Package: inn
  NVR: inn-2.4.3-9.fc8
  From Tag: dist-f8-updates-candidate
  Into Tag: dist-f8-updates-testing
  So from this time should be the update for rsyslog in testing repository 
  of F8.

> Entering a new bugzilla entry doesn't seem a bad idea, does it?
> Shall I title it 'news-entries missing in rsyslog.conf'?

  New bugzilla is good idea to not disturb previous bug reporter by our  
  discussion and to have the issue tracked. 
  Bug title is good - but in fact bug is now hopefully fixed in testing repo 
  so if your test of this update on F8 will be successful I could push it to 
  stable and there will be no need for additional comments and new bugzilla 
  ticket.
Comment 16 Eric de Hont 2008-01-18 16:57:59 EST
It being fridaynight and all, I installed it on my production system accidentally...

It's the ultimate test though, innit! ;-)

Good thing: nothing broke. The result is exactly as it should be:
]#  diff rsyslog.conf.org /etc/rsyslog.conf
7c7
< *.info;mail.none;authpriv.none;cron.none                /var/log/messages
---
> *.info;mail.none;news.none;authpriv.none;cron.none               
/var/log/messages
26a27,34
>
> #
> # INN
> #
> news.=crit                                        /var/log/news/news.crit
> news.=err                                         /var/log/news/news.err
> news.notice                                       /var/log/news/news.notice
> news.=debug                                       /var/log/news/news.debug

It seems to me this issue is resolved.

On topic: 'service innd restart' also still works!

Ondrej,
Thanks!

I look forward to being of any help in the future.

Greetings,
Eric

Note You need to log in before you can comment on or make changes to this bug.