Bug 401281 - Doesn'ŧ open task view
Doesn'ŧ open task view
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 11:28 EST by Matěj Cepl
Modified: 2008-11-06 14:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 14:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-11-27 11:28:44 EST
Version-Release number of selected component (if applicable):
eclipse-mylyn-bugzilla-2.0.0-9.fc8.x86_64 (updated from
http://sourceware.org/eclipse/update)
eclipse-platform-3.3.1.1-10.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Window/Show View/Task List
2.
3.
  
Actual results:
java.lang.NullPointerException
   at
org.eclipse.mylyn.internal.tasks.ui.views.AbstractFilteredTree.textChanged(org.eclipse.mylyn.tasks.ui_2.0.0.v20070627-1400.jar.so)
   at
org.eclipse.ui.dialogs.FilteredTree.setInitialText(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.mylyn.internal.tasks.ui.views.AbstractFilteredTree.<init>(org.eclipse.mylyn.tasks.ui_2.0.0.v20070627-1400.jar.so)
   at
org.eclipse.mylyn.internal.tasks.ui.views.TaskListFilteredTree.<init>(org.eclipse.mylyn.tasks.ui_2.0.0.v20070627-1400.jar.so)
   at
org.eclipse.mylyn.internal.tasks.ui.views.TaskListView.createPartControl(org.eclipse.mylyn.tasks.ui_2.0.0.v20070627-1400.jar.so)
   at
org.eclipse.ui.internal.ViewReference.createPartHelper(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.ViewReference.createPart(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.Perspective.showView(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPage.busyShowView(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPage.access$19(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPage$19.run(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.gtk.linux.x86_64_3.3.2.v3347.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPage.showView(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.WorkbenchPage.showView(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.ShowViewAction.run(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.jface.action.Action.runWithEvent(org.eclipse.jface_3.3.1.M20070910-0800b.jar.so)
   at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(org.eclipse.jface_3.3.1.M20070910-0800b.jar.so)
   at
org.eclipse.jface.action.ActionContributionItem.access$2(org.eclipse.jface_3.3.1.M20070910-0800b.jar.so)
   at
org.eclipse.jface.action.ActionContributionItem$5.handleEvent(org.eclipse.jface_3.3.1.M20070910-0800b.jar.so)
   at
org.eclipse.swt.widgets.EventTable.sendEvent(org.eclipse.swt.gtk.linux.x86_64_3.3.2.v3347.jar.so)
   at
org.eclipse.swt.widgets.Widget.sendEvent(org.eclipse.swt.gtk.linux.x86_64_3.3.2.v3347.jar.so)
   at
org.eclipse.swt.widgets.Display.runDeferredEvents(org.eclipse.swt.gtk.linux.x86_64_3.3.2.v3347.jar.so)
   at
org.eclipse.swt.widgets.Display.readAndDispatch(org.eclipse.swt.gtk.linux.x86_64_3.3.2.v3347.jar.so)
   at
org.eclipse.ui.internal.Workbench.runEventLoop(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.Workbench.runUI(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.Workbench.access$4(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.Workbench$4.run(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.core.databinding.observable.Realm.runWithDefault(org.eclipse.core.databinding_1.0.1.M20070822-0800.jar.so)
   at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.PlatformUI.createAndRunWorkbench(org.eclipse.ui.workbench_3.3.1.M20070921-1200.jar.so)
   at
org.eclipse.ui.internal.ide.application.IDEApplication.start(org.eclipse.ui.ide.application_1.0.0.I20070530-0100.jar.so)
   at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(org.eclipse.equinox.app_1.0.1.R33x_v20070828.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(org.eclipse.osgi_3.3.1.R33x_v20070828.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(org.eclipse.osgi_3.3.1.R33x_v20070828.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.3.1.R33x_v20070828.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.3.1.R33x_v20070828.jar.so)
   at java.lang.reflect.Method.invoke(libgcj.so.8rh)
   at
org.eclipse.equinox.launcher.Main.invokeFramework(org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar.so)
   at
org.eclipse.equinox.launcher.Main.basicRun(org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar.so)
   at
org.eclipse.equinox.launcher.Main.run(org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar.so)
   at
org.eclipse.equinox.launcher.Main.main(org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar.so)


Expected results:
task list (surprise ;-))

Additional info:
Comment 1 Andrew Overholt 2007-12-05 10:47:22 EST
Hi Matej,

(In reply to comment #0)
> Version-Release number of selected component (if applicable):
> eclipse-mylyn-bugzilla-2.0.0-9.fc8.x86_64 (updated from
> http://sourceware.org/eclipse/update)

What does "updated from" mean?  It shouldn't be updated.  Just use the RPMs.

I don't know how this could have happened, but try temporarily moving your
~/.eclipse out of the way.  Also, what is the output of this:

for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done
Comment 2 Bug Zapper 2008-05-14 00:01:02 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Alexander Kurtakov 2008-11-06 14:16:24 EST
Eclipse mylyn is now at version 3.0.3 and verified to work.
And there was no response from the reporter for more than a year.
Please reopen if the problem is still existing.

Note You need to log in before you can comment on or make changes to this bug.