Bug 401311 - UI Repository Manager writes in wrong format to /etc/yum.repos.d files
UI Repository Manager writes in wrong format to /etc/yum.repos.d files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 11:32 EST by Milan Crha
Modified: 2014-01-21 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 04:14:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2007-11-27 11:32:57 EST
Description of problem:
When I use Application->Add/Remove Software, Edit->Repositories, and check
something what was not checked before, like updates-testing Fedora 8 x86_64 for
me, then it changes enabled key in 
/etc/yum.repos.d/fedora-updates-testing.repo
but in a way that the line looks like this:
"enabled = 1" (quotes for clarity only).
The problem is that yum itself expects it without those spaces, so like
"enabled=1",
otherwise it doesn't work, i.e. it does not want to update from that repository.


Version-Release number of selected component (if applicable):
yum-metadata-parser-1.1.2-1.fc8
yum-3.2.7-1.fc8
yum-updatesd-0.7-1.fc8
yum-utils-1.1.8-1.fc8

How reproducible:
Always.

Actual results:
Repository is not enabled.

Expected results:
Repository should be enabled, even from UI.
Comment 1 Jeremy Katz 2007-11-27 13:38:02 EST
The format with the space should be fine -- python-iniparse is doing all of the
reading and writing.

Tim?
Comment 2 Tim Lauridsen 2007-11-28 03:17:05 EST
(In reply to comment #1)
> The format with the space should be fine -- python-iniparse is doing all of the
> reading and writing.
> 
> Tim?
Agree, 'enabled = 1' & 'enabled=1' both is working.

I cant reproduce this problem.

$ yum repolist
Loading "skip-broken" plugin
Loading "refresh-updatesd" plugin
repo id              repo name                                 status
fedora               Fedora 8 - x86_64                         enabled
livna                Livna for Fedora Core 8 - x86_64 - Base   enabled
updates              Fedora 8 - x86_64 - Updates               enabled
$ pirut
Edit -> Repositoties
Enabled the 'updates-testing' repo
Click on 'Close'
File -> Quit

$ yum repolist
Loading "skip-broken" plugin
Loading "refresh-updatesd" plugin
repo id              repo name                                 status
fedora               Fedora 8 - x86_64                         enabled
livna                Livna for Fedora Core 8 - x86_64 - Base   enabled
updates              Fedora 8 - x86_64 - Updates               enabled
updates-testing      Fedora 8 - x86_64 - Test Updates          enabled

Result is as expected 'updates-testing' is enabled now.

I think when you change the repos in pirut, you have to exit pirut and restart
it, too use the new repositories.


Comment 3 Milan Crha 2007-11-28 04:14:11 EST
OK, maybe it was the reason, I didn't restart pirut. Marking as NOTABUG, thanks
for explanation.

Note You need to log in before you can comment on or make changes to this bug.