Bug 40147 - Connecting network to pcmcia card freezes computer
Connecting network to pcmcia card freezes computer
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-10 18:30 EDT by Dwight Durmon
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:05:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwight Durmon 2001-05-10 18:30:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
When using a "Linksys EtherFast 10/100 + 56K Modem PC Card" (Model: 
PCMLM56), and version 3.1.24 release 2 of the kernel-pcmcia-cs, the card 
is recognized, but the PC will totally freeze up when you connect a 
network cable.

How reproducible:
Always

Steps to Reproduce:
1. Boot 7.1 with PCMCIA card removed.
2. Insert PCMCIA card and wait for Redhat to recognize it.
3. Insert network cable into card and watch PC freeze.
(NOTE: It doesn't matter if you use DHCP or a hard bound IP address, 
results are the same.)

Actual Results:  PC is totally locked up.  The only way to recover is to 
remove the power cord and battery (It's on a Compaq Armada 7400 Laptop).

Expected Results:  Should have been able to talk to the network.

Additional info:
Comment 1 Need Real Name 2001-07-10 03:32:01 EDT
I'm not alone!!

Thank god. I'd not worked it out exactly until I found this bug, but like the
guy says as soon as a network connection is made via the pcmcia card the machine
locks up completely.

My card in question is a 3Com 10/100 3CCFE574BT. I'm going to try and burn the
recent updates onto a cd and install the new kernel to see if that improves the
situation.
Comment 2 Need Real Name 2001-07-10 11:46:04 EDT
I can also reproduce the error.

Laptop Armada 7400, netcard: Edimax Ne2000 type.

I can avoid it crashing by doing an 'ifdown eth0' before connecting the net
connection to the netcard, however, it will crash the moment 'ifup eth0' is run.

It worked perfectly under 2.2.17 kernels. Btw. it seems to work fine under 
Suse 7.1




Note You need to log in before you can comment on or make changes to this bug.