Bug 401471 - connect column missing
connect column missing
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 12:35 EST by Pierre Ossman
Modified: 2007-12-18 12:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 12:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot.png (41.56 KB, image/png)
2007-11-27 18:11 EST, Pierre Ossman
no flags Details

  None (edit)
Description Pierre Ossman 2007-11-27 12:35:27 EST
I've been enjoying the new flashy bluetooth support in Fedora, using several
bluetooth HID devices on and off. Recently, however, things have gone completely
dead.

As I don't know how things are connected (please do enlighten), I'll start by
reporting the primary symptoms I see.

1. The connect colum in "Bluetooth preferences" is missing. I still have the
trusted and encrypted columns, but the connected column is just a single pixel wide.

2. The mouse cannot reconnect. Redoing the pairing song and dance gets it
working, but it can't reconnect on its own. This used to work, so it should be a
software problem on the laptop.

So right now I can't really use a bluetooth mouse as it isn't practical to
fiddle around that much whenever I leave it idle for too long.
Comment 1 Pierre Ossman 2007-11-27 13:03:24 EST
Playing around a bit more with the mouse, it seems software can't entirely be
blamed. The mouse had gotten into some weird ass state where it wouldn't make
any attempt to reconnect to the host. Stealing its batteries for a while got it
back into shape though. I have no idea how it got into the odd state, but the
problem can be ignored until I can reproduce it.

Playing a bit further also revealed the problem with the column display. It
seems the default size is a bit wrong. As long as something is connected it'll
resize itself properly. So it should be an easy fix.
Comment 2 Bastien Nocera 2007-11-27 17:13:28 EST
There's no default size, we're just using GTK+:
        gtk_tree_view_insert_column_with_data_func(GTK_TREE_VIEW(tree), -1,
                                "Bonded", gtk_cell_renderer_pixbuf_new(),
                                        bonded_to_icon, NULL, NULL);

So the column is only hidden/0-width when there's no connected devices, which
seems fine to me. Now if the size was a couple of pixels wide when there is a
device connected, it would be a bug? Did that happen? Got a screenshot?
Comment 3 Pierre Ossman 2007-11-27 18:11:03 EST
Created attachment 270561 [details]
screenshot.png

Included is the appearance without any connected the devices.

The column will then expand once a device is connected, but when it disconnects
the column width remains. Even if that wasn't the case, the narrow column just
looks weird and broken.
Comment 4 Bastien Nocera 2007-11-28 06:11:06 EST
Aww. It looks bad because your theme uses column separators. I guess all those
icons should be packed into one column.
Comment 5 Bastien Nocera 2007-12-18 12:58:10 EST
Filed upstream: http://bugzilla.gnome.org/show_bug.cgi?id=504293

Note You need to log in before you can comment on or make changes to this bug.