Bug 40148 - e100 driver always recompiled in 2.2.19-7.0.1
e100 driver always recompiled in 2.2.19-7.0.1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-10 18:34 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-10 18:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-10 18:34:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
The e100 network driver always gets recompiled, even if it's up to
date, because it was added to drivers/net/Makefile in the wrong way.


How reproducible:
Always

Steps to Reproduce:
1."make modules"
2."make modules"
3.
	

Actual Results:  e100.c will be compiled the second time even though
nothing has changed.

Expected Results:  e100.c should not have been recompiled the second time.

Additional info:

Here's a patch for drivers/net/Makefile to fix it:
--- linux-2.2.19/drivers/net/Makefile.orig      Mon Apr  9 22:29:49 2001
+++ linux-2.2.19/drivers/net/Makefile   Thu May 10 15:46:05 2001
@@ -35,6 +35,8 @@
 CONFIG_SYNCPPP_BUILTIN :=
 CONFIG_SYNCPPP_MODULE  :=
 
+CFLAGS_e100.o = -DEXPORT_SYMTAB
+
 ifeq ($(CONFIG_ISDN),y)
   ifeq ($(CONFIG_ISDN_PPP),y)
     CONFIG_BSDCOMP_BUILTIN = y
@@ -1483,9 +1485,6 @@
 
 rcpci.o: rcpci45.o rclanmtl.o
        $(LD) -r -o rcpci.o rcpci45.o rclanmtl.o
-
-e100.o: e100.c e100.h
-       $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(INCLUDE) -DEXPORT_SYMTAB -c -o
$*.o $<
 
 e1000.o: e1000_main.o e1000_fxhw.o
        $(LD) -r -o e1000.o e1000_main.o e1000_fxhw.o
Comment 1 Arjan van de Ven 2001-05-11 04:54:50 EDT
Thanks for the report. I've fixed this for the next 2.2 build.
(I'm closing this as "fixed in rawhide" even though it isn't available yet)

Note You need to log in before you can comment on or make changes to this bug.