This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 401491 - no DVD-RW or Floppy drive entries added to /etc/fstab
no DVD-RW or Floppy drive entries added to /etc/fstab
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 12:38 EST by Keith Roberts
Modified: 2007-12-01 14:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 13:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith Roberts 2007-11-27 12:38:45 EST
Description of problem:

Anaconda dose not add entries for the /dev/fd0 floppy drive, or the /dev/sr0 
DVD-RW drive to the /etc/fstab file.

How reproducible:

Always

Steps to Reproduce:
1. Do a fresh install of F8 and check the contents of your /etc/fstab file.
  
Actual results:

The default /etc/fstab after a fresh installation looks like this on my 
system:

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/tmp              /tmp                    ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda10        swap                    swap    defaults        0 0

Expected results:

I expect the installation program to detect my floppy drive and DVD-RW drive, 
and add appropriate entries to the /etc/fstab file for each device, and also 
create the mountpoints for those devices under /media.

Additional info:

I had to hunt around in /var/log/dmsg and find out the name of the device that 
my DVD-RW was attached to. I then added the following entries to my /etc/fstab 
file:

/dev/fd0        /media/floppy        auto       noauto,user,sync       0 0

# DVD-RW drive VOM-12E48X
/dev/sr0        /media/dvdrecorder   iso9660    rw,user,noauto,unhide  0 0

I then had to create the mount points in /media for floppy and dvdrecorder.
Comment 1 Jeremy Katz 2007-11-27 13:38:25 EST
They're not added intentionally.  Use gnome-mount (or mounting within nautilus,
konqueror, etc) instead
Comment 2 Keith Roberts 2007-12-01 14:23:22 EST
Thankyou Jeremy. That's fine if one is using X. What if someone is running a 
bar http or other server without X? They might want to make backups of some 
data or configuration files to DVD/CDROM. So how would they mount the DVD/CD 
drive then without having the relevant entries in /etc/fstab and the mount 
points?

I have added the above two entries to my fstab, and still have HAL running as 
well. There does not seem to be any conflicts with this setup :)

Note You need to log in before you can comment on or make changes to this bug.