Bug 401501 - Satellite Exporter Cache Files Being Written With Wrong Encoding
Satellite Exporter Cache Files Being Written With Wrong Encoding
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Amy Owens
US=17470
: Reopened, Triaged
: 462693 (view as bug list)
Depends On:
Blocks: 345571 382381 428808 428922 GSS_HOSTED_Tracker
  Show dependency treegraph
 
Reported: 2007-11-27 12:40 EST by Devan Goodwin
Modified: 2013-01-10 04:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 17:52:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2007-11-27 12:40:16 EST
Satellite bug #382381 uncovered a problem where package summaries
(Virtualization-ru-RU for example) were appearing in a mangled state. Problem
was not present in hosted's display of these packages, and the problem was
traced to the satellite exporter's cache files being written to disk without the
proper encoding. More details on specifics can be found in the original ticket.

Steps to Reproduce:

1. View the cached data for Virtualization-ru-RU package.
  
Actual results:

Ð Ñ<83>ководÑ<81>Ñ<82>во по виÑ<80>Ñ<82>Ñ<83>ализаÑ<86>ии

Expected results:

Руководство по виртуализации
Comment 1 James Bowes 2008-06-26 11:01:26 EDT
To test:
 * Make sure that on the scripts box, /var/cache/rhn/xml-* has been removed
 * register a statellite to the target env
 * run satellite sync for rhel 5 channels and virtualization channels
 * on your satellite, ensure that all of the virtualization-ru-ru packages show
cyrilic characters in their descriptions.
Comment 2 Amy Owens 2008-07-02 15:40:26 EDT
now in dev I see:   Руководство по виртуализации
Comment 3 Amy Owens 2008-07-16 15:59:33 EDT
all set in dev
Comment 5 Amy Owens 2008-09-08 15:21:47 EDT
not testing in qa-- do not want to blow away the cache again for sat folks-- tested in dev all set
Comment 6 Amy Owens 2008-09-18 15:49:36 EDT
so we need to back this out of RHN 507 and sdd to 508 /sprint 12
Comment 7 Jeff Browning 2008-09-18 16:07:35 EDT
Repro steps:

1) Installed Sat 520 i386 on RHEL4
2) Using the dump, sat-synced the i386 channels for RHEL 4 base and tools, and RHEL 5 base, tools, and virt.
3) satellite-sync from Web QA to check and update these channels since the dump is not 100% up to date.
4) Got the following error:

Exception type satellite_tools.xmlSource.FatalParseException

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 123, in process
    self.__parser.parse(self.__stream)
  File "/usr/lib/python2.3/site-packages/_xmlplus/sax/expatreader.py", line 109, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/lib/python2.3/site-packages/_xmlplus/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/lib/python2.3/site-packages/_xmlplus/sax/expatreader.py", line 220, in feed
    self._err_handler.fatalError(exc)
  File "/usr/share/rhn/satellite_tools/xmlSource.py", line 233, in fatalError
    raise FatalParseException(e._msg, e, e._locator)
FatalParseException: :489:1015: not well-formed (invalid token)

5) Tried the channels one at a time. RHEL 4 tools worked, but RHEL 4 and 5 base channels still gave this error.
Comment 8 Brandon Perkins 2008-09-18 18:12:10 EDT
*** Bug 462693 has been marked as a duplicate of this bug. ***
Comment 9 Amy Owens 2008-09-25 08:25:01 EDT
added to sprint 13
Comment 10 Amy Owens 2008-09-30 10:11:09 EDT
moving out of 508-- into sprint 14
Comment 11 Amy Owens 2008-10-30 10:57:36 EDT
moving back out to backlog
Comment 16 Amy Owens 2009-01-30 11:23:41 EST
This can NOT be fixed-
from hosted Topics Meeting on 1/19/09
"BZ 401501 - Hosted will close, no obvious solution, broken encoding for Sat generally breaks Hosted also"


https://engineering.redhat.com/trac/rhn-hosted/wiki/BRB

Note You need to log in before you can comment on or make changes to this bug.