Bug 40163 - /usr/lib/rpm/rpmrc: wrong location of per-system rpmrc
/usr/lib/rpm/rpmrc: wrong location of per-system rpmrc
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-10 19:07 EDT by Ville Skyttä
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 04:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2001-05-10 19:07:09 EDT
In rpm-4.0.2-8, the location of per-system rpmrc is said to be
/etc/rpm/rpmrc, however, adding stuff there won't be used. The comments
there should maybe be corrected to refer to /etc/rpmrc.

BTW, shouldn't the per-system rpmrc be in /etc/rpm/ instead of /etc/ ?
Comment 1 Jeff Johnson 2001-05-10 19:15:37 EDT
Where is the false claim /etc/rpm/rpmrc?

Yes, it *should* be /etc/rpm/rpmrc, but the original location was /etc/rpmrc.
Isn't legacy wonderful?
Comment 2 Ville Skyttä 2001-05-11 04:24:04 EDT
Whoops, forgot to put the location in the description, but as the summary says,
the claim is in the beginning of /usr/lib/rpm/rpmrc.
Comment 3 Jeff Johnson 2001-05-11 13:21:16 EDT
Fixed in rpm CVS, thanks for noticing.
Comment 4 Curtis Doty 2001-05-22 13:00:16 EDT
So I tested /etc/rpm/rpmrc to no avail. It looks like rpm-4.0.2-8 really only 
checks /etc/rpmrc but future versions will also check for /etc/rpm/rpmrc right?

Anyways, FYI, here's where both are referenced:

$ strings --print-file-name `rpm -ql rpm` 2>/dev/null |grep /etc/rpm/rpmrc 
/usr/lib/rpm/rpmrc: # should be added to /etc/rpm/rpmrc, while per-user 
configuration should

$ strings --print-file-name `rpm -ql rpm` 2>/dev/null |grep /etc/rpmrc
/bin/rpm: use <file> instead of /etc/rpmrc and $HOME/.rpmrc
/bin/rpm: /usr/lib/rpm/rpmrc:/etc/rpmrc:~/.rpmrc
/usr/lib/librpm.so.0: /usr/lib/rpm/rpmrc:/etc/rpmrc:~/.rpmrc
/usr/lib/librpm.so.0.0.0: /usr/lib/rpm/rpmrc:/etc/rpmrc:~/.rpmrc
/usr/lib/rpm/convertrpmrc.sh: # Convert per-system configuration in /etc/rpmrc 
to macros in /etc/rpm/macros.
/usr/lib/rpm/convertrpmrc.sh: [ -z "$RPMRC" ] && RPMRC=/etc/rpmrc
/usr/share/doc/rpm-4.0.2/CHANGES:       - convert per-system configuration 
in /etc/rpmrc to macros.
/usr/share/doc/rpm-4.0.2/CHANGES:         /etc/rpmrc
/usr/share/doc/rpm-4.0.2/CHANGES:       - removed /etc/rpmrc from standard 
distribution
/usr/share/doc/rpm-4.0.2/CHANGES:       - added arch_compat handling 
in /etc/rpmrc
/usr/share/doc/rpm-4.0.2/CHANGES:       - added build_arch to /etc/rpmrc
/usr/share/doc/rpm-4.0.2/macros:        In /etc/rpmrc and/or ~/.rpmrc you put
Comment 5 Jeff Johnson 2001-05-22 13:08:36 EDT
The comment only was changed, rpm, as always, reads from /etc/rpmrc. 'Twould be
more
logical to read from /etc/rpm/rpmrc, can't be helped.

Note You need to log in before you can comment on or make changes to this bug.