Bug 40169 - (SiS 530) XFree86 misrendering and wrong modes
Summary: (SiS 530) XFree86 misrendering and wrong modes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-11 01:41 UTC by Alan Cox
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 23:09:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci for the machine (2.01 KB, text/plain)
2001-05-11 01:42 UTC, Alan Cox
no flags Details
SIS XF86config (9.08 KB, text/plain)
2001-05-12 10:32 UTC, Alan Cox
no flags Details

Description Alan Cox 2001-05-11 01:41:12 UTC
Doing a graphical install on a SIS530 integrated mainboard works up to a
point then it starts rendering some white areas as black making it kind of
tricky to work with. Ive not seen this after install which is odd ?

The beta X server was ok minus the fact scrolling occasionalyl corrupted
the cursor

Secondly the display height is too large. On my generic 640x480 vga dislay
the picture goes over the top and bottom. Other cards seem to be ok
suggesting a card/table problem.

Comment 1 Alan Cox 2001-05-11 01:42:38 UTC
Created attachment 18067 [details]
lspci for the machine

Comment 2 Mike A. Harris 2001-05-12 07:48:59 UTC
Can you attach a server log + config file?  Probably using a bad modeline for
your monitor.  xvidtune will likely help configure a working mode for you
if you cant get X to sanely do so itself.  If you generate a working modeline,
attach it and I'll see if I can get it into either X or Xconfigurator.

If 4.0.3-5 or 4.0.3-14 works well with the card though, let me know since we'll
be dropping 3.3.6 most likely in the not distant future and theres no
use fiddling with 3.3.6 if it can be avoided by using 4.x.  The installer
will likely use 4.x FBdev for installation in our next release whereas it uses
3.3.x for some reason in 7.0/7.1  Me and msf need to talk about this...


Comment 3 Alan Cox 2001-05-12 10:31:44 UTC
Does this mean that the MediaGX, S3 968, S3 Trio and Imagine 128 etc servers are
now finally ported over.. that would be great news

I've attached the XF86Config. It looks right. Its just the display isnt. Dunno
if its just crap cards or what.


Comment 4 Alan Cox 2001-05-12 10:32:36 UTC
Created attachment 18188 [details]
SIS XF86config

Comment 5 Mike A. Harris 2001-05-24 20:54:44 UTC
S3 drivers are indeed being ported finally. A fellow named Ani Joshi is doing
S3 work.  If you have, or can obtain hardware, Ani is willing to port the
stuff.  He's already got 968 and Trio working I believe.  I'll have to check
it out again prior to our next release.  3.3.6 will be here as long as it is
needed though.  I think a lot of what needs to be done will be done in a year,
so probably around the time XFree 4.2.x is out, we may no longer need 3.3.6.

I need your X server log to go with the config still...

Also, I've got a pending errata release ready for 3.3.6.  Currently it
is the 3.3.6-38 rpm's on porky (and people.redhat.com/mharris/testing).
If you try them, please let me know any good/bad changes.  In particular
there are numerous major updates to the S3 drivers, including the cards
you have mentioned.
TTYL

Comment 6 Alan Cox 2001-05-24 22:40:35 UTC
I can try them on the SiS and the Cyrix MediaGX. I think my S3 card went out in
a server to someone though


Comment 7 Mike A. Harris 2002-08-20 10:38:43 UTC
This should all be fixed / workedaround in rawhide currently and current
beta's.  The solution is in the hwdatabase Cards file, which disables
the faulty hardware cursor using Option "swcursor".

I'm setting the bug report to MODIFIED.  If you can test and confirm,
then set to RAWHIDE if it is ok (which it should be now), or reopen
for tweaking with XaaNo options..

TIA


Note You need to log in before you can comment on or make changes to this bug.