Bug 401761 - libnl update (for knetworkmanager)
libnl update (for knetworkmanager)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libnl (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 16:00 EST by Rex Dieter
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.17-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 18:09:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-11-27 16:00:10 EST
newer versions of knetworkmanager require libnl >= 1.0-pre6, and we've also
noticed that our existing knetworkmanager builds against libnl-1.0-pre5
experience some pretty drastic memory leaks that are presumably fixed in newer
releases of libnl.

Just checked, libnl-1.0-pre8 is the latest available upstream.
Comment 1 Dan Williams 2007-12-03 10:20:20 EST
yep, we need to update libnl in F8 and devel and push the libnl-pre8 patch
upstream to NM SVN.
Comment 2 Dennis Gilmore 2007-12-03 10:33:33 EST
and F-7 also?
Comment 3 Dan Williams 2007-12-03 10:36:55 EST
Well; why?  The only reason to update F7's libnl is if F7 gets a 2.6.24 kernel
update, which is the whole reason why -pre7 and later are necessary.  Note that
-pre7 is ABI _in_compatible with earlier releases; so we should have a good
reason to push an F7 update other than "it's better" I think.
Comment 4 Rex Dieter 2007-12-03 10:49:55 EST
Does "because it closes a large reported memory leak" not count as a good enough
reason?
Comment 5 Christopher Aillon 2007-12-03 11:01:48 EST
No.  Because we can backport fixes at the maintainer's discretion.
Comment 6 Dan Williams 2007-12-03 11:19:38 EST
It might be good enough to update.  We need to figure out what other packages
might use libnl, then make a decision as to whether we can break the API/ABI and
require rebuilds of those just to make stuff work for NM/knetworkmanager.
Comment 7 Rex Dieter 2007-12-03 11:27:31 EST
Also consider that knetworkmanger updates are blocked until libnl is updated (to
libnl >= 1.0-pre6)
Comment 8 Dennis Gilmore 2007-12-03 11:36:59 EST
and that there is a memory leak with the current libnl knetworkmanager 
combination.  i have seen knm use 1gb ram as a result
Comment 9 Neil Horman 2007-12-03 11:50:57 EST
is there a particular reason that you're looking specifically at pre6?  From
what I see, pre8 is the latest available.
Comment 10 Dennis Gilmore 2007-12-03 11:56:20 EST
http://mail.kde.org/pipermail/kde-networkmanager/2007-November/000251.html

the next release of knetworkmanager for the 0.6.5 branch of NM  requires at 
least pre6 
Comment 11 Dan Williams 2007-12-03 17:25:30 EST
NM currently doesn't work with 2.6.22.9-91.fc7 and libnl-1.0-pre8, erroring out
with malformed netlink message errors deep inside libnl somewhere.  Until that's
figured out, this ain't gonna happen.

NetworkManager: <info>  Bringing up device eth0
-- Error: Invalid message: type=0x10 length=252 flags=<MULTI>
sequence-nr=1196720416 pid=4294963195
Comment 12 Dan Williams 2007-12-17 23:07:57 EST
Issues resolved, pushing out updates for rawhide and F8.
Comment 13 Dennis Gilmore 2007-12-17 23:31:29 EST
what about f7
Comment 14 Dan Williams 2007-12-18 14:13:40 EST
For F7, we have to work a bit harder because NM in F7 uses netlink to receive
wireless events too, which libnl does not handle currently.
Comment 15 Fedora Update System 2008-01-06 20:19:37 EST
NetworkManager-0.7.0-0.6.7.svn3204.fc8, libdhcp-1.27-4.fc8, libnl-1.0-0.15.pre8.git20071218.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager libdhcp libnl'
Comment 16 Dennis Gilmore 2008-01-06 21:25:19 EST
again this bug is for Fedora 7 not Fedora 8 
Comment 17 Fedora Update System 2008-01-22 11:01:50 EST
NetworkManager-0.7.0-0.6.7.svn3204.fc8, libdhcp-1.27-4.fc8, libnl-1.0-0.15.pre8.git20071218.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Dan Williams 2008-02-11 23:31:00 EST
1.1 for F7: please test knetworkmanager builds against it.  Of course NM won't
run with this build until I update NM, but it would be useful to know if there
are build time issues with knm too.

http://koji.fedoraproject.org/koji/taskinfo?taskID=417400
Comment 19 Fedora Update System 2008-03-07 14:52:24 EST
netlabel_tools-0.17-6.fc7, libdhcp-1.24-6.fc7, NetworkManager-0.6.6-1.fc7, libnl-1.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netlabel_tools libdhcp NetworkManager libnl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2346
Comment 20 Fedora Update System 2008-03-21 18:09:05 EDT
netlabel_tools-0.17-6.fc7, libdhcp-1.24-6.fc7, NetworkManager-0.6.6-1.fc7, libnl-1.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.