Bug 401801 - ATI mobility radeon black screen and hang
ATI mobility radeon black screen and hang
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 16:28 EST by Robert Peterson
Modified: 2008-03-30 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 21:56:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log for the problem (42.29 KB, text/plain)
2007-11-27 16:30 EST, Robert Peterson
no flags Details
Log file with dri disabled (38.49 KB, text/plain)
2007-11-27 17:22 EST, Robert Peterson
no flags Details
Xorg.0.log with "bustype" "PCI" (41.93 KB, text/plain)
2007-11-27 18:09 EST, Robert Peterson
no flags Details

  None (edit)
Description Robert Peterson 2007-11-27 16:28:35 EST
Description of problem:
This may turn out to be the same as bug #399021.
I upgraded my laptop from F7 to F8.  X worked perfectly under F7,
but under F8, I just get a black screen (i.e. not backlight) and
the system becomes unresponsive.  I can't exit X.

If I boot at runlevel 3, then do startx, I get a screen that is
hosed, but the backlight is on.  I can see the "X" and move it
around with my mouse, but the top tenth of the screen is filled
with lots of blue and red blotches.  About a third of the way down
the screen, there's another very light streak of indiscernible
graphics.  I never get the gnome screen.
I can ssh into the system.  I tried killing X, but it didn't die.
It's stuck at 100% cpu utilization.

Version-Release number of selected component (if applicable):
Latest F8 updates.
xorg-x11-drv-ati-6.7.196-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Turn on my Sharp Actius MP30
2. Watch it go bye-bye.
  
Actual results:
Black screen, unresponsive

Expected results:
X should work normally.

Additional info:
My xorg.conf:

# Xorg configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

I'll attach my log file afterward.
Comment 1 Robert Peterson 2007-11-27 16:30:42 EST
Created attachment 270261 [details]
Xorg.0.log for the problem

Here's the matching Xorg.0.log file.
Comment 2 Robert Peterson 2007-11-27 16:49:58 EST
lspci:

00:00.0 Host bridge: Transmeta Corporation TM8000 Northbridge
00:01.0 PCI bridge: Transmeta Corporation TM8000 AGP bridge
00:02.0 PCI bridge: ALi Corporation M5249 HTT to PCI Bridge
00:03.0 ISA bridge: ALi Corporation M1563 HyperTransport South Bridge (rev 20)
00:03.1 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:04.0 Multimedia audio controller: ALi Corporation M5455 PCI AC-Link
Controller Audio Device (rev 10)
00:04.1 Modem: ALi Corporation M5457 AC'97 Modem Controller (rev 10)
00:06.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
(rev 01)
00:09.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 81)
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0e.0 IDE interface: ALi Corporation M5229 IDE (rev c5)
00:0f.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0f.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW
[Radeon Mobility 7500]

FYI: The graphic screen presented during INIT is perfect.
Comment 3 Robert Peterson 2007-11-27 17:05:19 EST
I added:

Option      "bustype" "pci"

to the Device section, but it had no effect.
Under the direction of David Airlie, I added:

Option      "dri" "false"

to the Device section and it works okay now.  So apparently the problem
is in dri.
Comment 4 Robert Peterson 2007-11-27 17:22:00 EST
Created attachment 270431 [details]
Log file with dri disabled
Comment 5 Robert Peterson 2007-11-27 17:58:53 EST
It works okay with "bustype" "PCI" so apparently case matters.
It also works if I take out "bustype" "PCI" and "dri" "false"
(dri enabled) but add this:
Option      "AGPMode" "1"
Comment 6 Robert Peterson 2007-11-27 18:09:55 EST
Created attachment 270551 [details]
Xorg.0.log with "bustype" "PCI"
Comment 7 Dave Airlie 2008-03-30 21:55:45 EDT
not much we can do about this, try the latest updates testing branch it defaults
to using a low AGP rate..

AGP is just plain badly implemented in a lot of hardware.
Comment 8 Robert Peterson 2008-03-30 22:44:07 EDT
Well, I've successfully circumvented the problem (as above) so I'm not
interested in pursuing this problem.  Feel free to close it "wontfix".

Note You need to log in before you can comment on or make changes to this bug.