Bug 401821 - anaconda doesn't probe for USB on buses other than PCI and PS3
anaconda doesn't probe for USB on buses other than PCI and PS3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 16:29 EST by David Woodhouse
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 16:52:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2007-11-27 16:29:22 EST
Could do with it checking MACIO (which is actually BUS_OPENFIRMWARE) too. In
fact, why isn't it BUS_UNSPEC?

--- a/loader2/usb.c
+++ b/loader2/usb.c
@@ -73,7 +73,7 @@ int usbInitialize(moduleList modLoaded, moduleDeps modDeps,
 
     logMessage(INFO, "looking for usb controllers");
 
-    devices = probeDevices(CLASS_USB, BUS_PCI | BUS_PS3, 0);
+    devices = probeDevices(CLASS_USB, BUS_PCI | BUS_PS3 | BUS_MACIO, 0);
 
     if (!devices) {
         logMessage(DEBUGLVL, "no usb controller found");
Comment 1 Chris Lumens 2007-11-27 16:52:32 EST
Because the patch you supplied in bug 236480 didn't do BUS_UNSPEC.  :)

Applied.
Comment 2 David Woodhouse 2007-11-27 16:55:11 EST
Then, as now, I didn't know if there was actually a reason to avoid some bus types.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.