Bug 40192 - Sendmail does not creates the sendmail.st file
Summary: Sendmail does not creates the sendmail.st file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-11 06:38 UTC by Tibor SANDOR
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 06:38:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tibor SANDOR 2001-05-11 06:38:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Terminal)

Description of problem:
Try to run the command mailstats on a freshly installed RH 7.1.
The ansver is there is no sendmail.st file.

After touch /var/log/sendmail.st it works.

How reproducible:
Always

Steps to Reproduce:
1. mailstats
2.
3.
	

Additional info:

Comment 1 Florian La Roche 2001-05-15 16:02:11 UTC
sendmail.st is never created automatically. Once to do that, sendmail will start
putting
together statistics for you.

So should be all fine,

Florian La Roche


Comment 2 Michael Schwendt 2001-05-28 22:04:28 UTC
What is the empty /var/log/statistics then which is included in the rpm?

Isn't it /etc/mail/statistics as mentioned in "man sendmail"? But Red Hat has
defined it to be

  define(`STATUS_FILE', `/var/log/sendmail.st')dnl

in both these files:

  /usr/share/sendmail-cf/cf/redhat.mc
  /etc/mail/sendmail.mc

I think the original reporter is right, and this is a bug with a trivial fix.



Comment 3 Curtis Doty 2001-07-17 01:44:56 UTC
Agreed, this is a bug and RedHat should figure out whether they want to 
use /var/log/senmail.st, (which reqires manual intervention to activate) 
or /var/log/statistics (which is installed but never used). Argh! Figure it out 
guys!

BTW, I upgraded to my current sendmail-8.11 from an older 8.9 (maybe lunar 
penguin?). Thus, the above bug effectively disabled statistics on my server 
since it renamed the old /var/log/sendmail.st, but installed a 
useless /var/log/statistics.


Note You need to log in before you can comment on or make changes to this bug.